<!DOCTYPE html>
<html lang="en-US"
 xmlns:fb="http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://theredshtick.com/xmlrpc.php" />
<title>GUEST COLUMN: &#8220;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&#8221; — John Kennedy</title>
<style type="text/css">#page{overflow:visible}.ngfb-buttons{}.ngfb-buttons
img{border:none}.ngfb-buttons img:hover{border:none}.ngfb-buttons
iframe{max-width:none}.ngfb-buttons>div{display:inline-block;vertical-align:bottom;text-align:left;line-height:20px;width:100px;height:20px;padding:0;margin:2px}.ngfb-buttons div.facebook-button{width:149px}.ngfb-buttons div.gplus-button{width:99px}.ngfb-buttons div.gplusone-button{width:75px}.ngfb-buttons div.twitter-button{width:89px}.ngfb-buttons div.linkedin-button{width:110px}.ngfb-buttons div.managewp-button{width:100px}.ngfb-buttons div.stumbleupon-button{width:84px}.ngfb-buttons div.pinterest-button{width:78px}.ngfb-buttons div.tumblr-button{width:81px}.ngfb-buttons div.fb-share-button{width:105px}.ngfb-buttons div.fb-share-button
span{display:block !important;vertical-align:middle !important}.ngfb-content-buttons{display:block;margin:15px
auto 15px auto;text-align:center}.ngfb-excerpt-buttons{display:block;margin:10px
auto 10px auto;text-align:center}#ngfb-sidebar{display:block;cursor:pointer;text-align:center;position:fixed;padding:0;z-index:99;top:20%;right:50%;margin:0
485px 0 0}#ngfb-sidebar-header{display:block;width:62px;height:62px;padding:0;margin:5px;background-image:url("http://theredshtick.com/wp-content/plugins/nextgen-facebook/images/share-icon-1.png");background-repeat:no-repeat;background-position:center}#ngfb-sidebar-buttons{display:none;margin:10px
0 0 0;border-radius:5px;background:none repeat scroll 0% 0% rgb(250, 250, 250);box-shadow:0px 0px 5px rgb(120, 120, 120);border:1px
solid rgb(255, 255, 255)}#ngfb-sidebar .ngfb-buttons>div{display:block;text-align:center;padding:0;width:60px;height:65px;line-height:65px;margin:10px
5px}#ngfb-sidebar .ngfb-buttons div.gplus-button>div{text-align:center;width:60px !important}#ngfb-sidebar .ngfb-buttons div.gplus-button>div>iframe{width:auto !important}#ngfb-sidebar .ngfb-buttons div.pinterest-button>a{vertical-align:bottom !important}#ngfb-sidebar .ngfb-buttons div.tumblr-button{height:20px;line-height:20px}.ngfb-admin_edit-buttons{text-align:left}.ngfb-admin_edit-buttons .ngfb-buttons{margin:0}.ngfb-admin_edit-buttons .ngfb-buttons>div{display:inline-block;vertical-align:top;padding:0;margin:5px;height:20px;width:120px}.ngfb-shortcode-buttons{display:inline-block;text-align:left}.ngfb-widget-buttons{text-align:left}.ngfb-widget-buttons .ngfb-buttons{margin:0}.ngfb-widget-buttons .ngfb-buttons>div{display:block;padding:3px;width:160px}</style>

<!-- Ads on this site are served by WP PRO Advertising System - All In One Ad Manager v4.6.8 - http://bit.ly/WPPROADSYSTEM -->
<!-- / WP PRO Advertising System - All In One Ad Manager. -->


<!-- All in One SEO Pack 2.3.11.2 by Michael Torbert of Semper Fi Web Design[342,482] -->
<meta name="description"  content="I finally made it. I am, at long last, a United States senator, and boy, does it feel dreamy." />

<meta name="keywords"  content="opinion,politics,john kennedy,senator,fulfills,louisiana,religion,movies,star trek generations,nexus,picard,kirk,captain,burning man,euphoric,holy spirit,whoopi goldberg,guinan,joy,jeff sessions,attorney general,josh groban,music,zachary,current events,movies &amp; tv" />

<link rel="canonical" href="http://theredshtick.com/2017/02/07/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Red Shtick &raquo; Feed" href="http://theredshtick.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Red Shtick &raquo; Comments Feed" href="http://theredshtick.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/theredshtick.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='clammr-player-style-css'  href='http://theredshtick.com/wp-content/plugins/audio-player-by-clammr/css/clammr-audio-player.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='http://theredshtick.com/wp-includes/js/mediaelement/mediaelementplayer.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://theredshtick.com/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_stylesheet-css'  href='http://theredshtick.com/wp-content/plugins/captcha/css/front_end_style.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://theredshtick.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css'  href='http://theredshtick.com/wp-content/plugins/captcha/css/desktop_style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='http://theredshtick.com/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='http://theredshtick.com/wp-content/themes/sahifa/css/ilightbox/mac-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='http://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='http://theredshtick.com/wp-content/plugins/tablepress/css/default.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-basic-css'  href='http://theredshtick.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-basic.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://theredshtick.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='http://theredshtick.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"en-US","strings":{"Close":"Close","Fullscreen":"Fullscreen","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Download File":"Download File","Download Video":"Download Video","Play":"Play","Pause":"Pause","Captions\/Subtitles":"Captions\/Subtitles","None":"None","Time Slider":"Time Slider","Skip back %1 seconds":"Skip back %1 seconds","Video Player":"Video Player","Audio Player":"Audio Player","Volume Slider":"Volume Slider","Mute Toggle":"Mute Toggle","Unmute":"Unmute","Mute":"Mute","Use Up\/Down Arrow keys to increase or decrease volume.":"Use Up\/Down Arrow keys to increase or decrease volume.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds."}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theredshtick.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-includes/js/mediaelement/wp-mediaelement.min.js'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-content/plugins/audio-player-by-clammr/js/clammr-audio-player.js'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-content/plugins/wp_pro_ad_system/templates/js/advertising.js'></script>
<link rel='https://api.w.org/' href='http://theredshtick.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://theredshtick.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://theredshtick.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Islamic State Reaffirms Desire to Kill All Humanity, Not Just Americans, Despite Trump&#8217;s Provocations' href='http://theredshtick.com/2017/02/06/islamic-state-reaffirms-desire-to-kill-all-humanity-not-just-americans-despite-trumps-provocations/' />
<meta name="generator" content="WordPress 4.7.2" />
<link rel="alternate" type="application/json+oembed" href="http://theredshtick.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheredshtick.com%2F2017%2F02%2F07%2Fguest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://theredshtick.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheredshtick.com%2F2017%2F02%2F07%2Fguest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy%2F&#038;format=xml" />
<!-- <meta name="NextGEN" version="2.1.69" /> -->
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create', 'UA-47029214-1', 'auto', 'clammrTracker');ga('clammrTracker.send', 'event', 'WordpressPlugin', 'PluginLoaded',  window.location.hostname);</script><meta property="fb:app_id" content="425616237478481"/><meta property="fb:admins" content="edie.white"/><script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<link rel="alternate" type="application/rss+xml" title="" href="http://theredshtick.com/feed/podcast/" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="http://theredshtick.com/wp-content/uploads/2016/04/cropped-RedShtickMan-TOP-667x667.png" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="http://theredshtick.com/wp-content/themes/sahifa/js/html5.js"></script>
<script src="http://theredshtick.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="http://theredshtick.com/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="http://theredshtick.com/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="http://theredshtick.com/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://theredshtick.com/wp-content/uploads/2016/04/TRS-icon-144x144.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="http://theredshtick.com/wp-content/uploads/2016/04/TRS-icon-120x120.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="http://theredshtick.com/wp-content/uploads/2016/04/TRS-icon-72x72.png" />
<link rel="apple-touch-icon-precomposed" href="http://theredshtick.com/wp-content/uploads/2016/04/TRS-icon-57x57.png" />

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6698439191164571",
    enable_page_level_ads: true
  });
</script>

<style type="text/css" media="screen">

body.single .entry, body.page .entry{
	font-size : 15px;
}

::-webkit-scrollbar {
	width: 8px;
	height:8px;
}

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #ef3636;
}

.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#ef3636;
}

::-webkit-scrollbar-thumb{
	background-color:#ef3636 !important;
}

#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box {
	border-top-color: #ef3636;
}

.search-block:after {
	border-right-color:#ef3636;
}

body.rtl .search-block:after {
	border-left-color:#ef3636;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #ef3636;
}

.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #ef3636;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #ef3636;
	border-color: #ef3636;
}

#order_review,
#order_review_heading {
	border-color: #ef3636;
}


body {
	background-image : url(http://theredshtick.com/wp-content/themes/sahifa/images/patterns/body-bg35.png);
	background-position: top center;
}

a:hover {
	color: #cd0000;
}
		
body.single .post .entry a, body.page .post .entry a {
	color: #cd0000;
}
		
body.single .post .entry a:hover, body.page .post .entry a:hover {
	color: #ff0000;
}
		
</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"http:\/\/theredshtick.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"http:\/\/theredshtick.com\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		<style type="text/css">/* MailChimp for WP - Checkbox Styles */
.mc4wp-checkbox-wp-registration-form {
  clear: both;
  display: block;
  position: static;
  width: auto; }
  .mc4wp-checkbox-wp-registration-form input {
    float: none;
    width: auto;
    position: static;
    margin: 0 6px 0 0;
    padding: 0;
    vertical-align: middle;
    display: inline-block !important;
    max-width: 21px;
    -webkit-appearance: checkbox; }
  .mc4wp-checkbox-wp-registration-form label {
    float: none;
    display: block;
    cursor: pointer;
    width: auto;
    position: static;
    margin: 0 0 16px 0; }
</style>
<style type="text/css">

/*
PowerPress subscribe sidebar widget
*/
.widget-area .widget_powerpress_subscribe h2,
.widget-area .widget_powerpress_subscribe h3,
.widget-area .widget_powerpress_subscribe h4,
.widget_powerpress_subscribe h2,
.widget_powerpress_subscribe h3,
.widget_powerpress_subscribe h4 {
	margin-bottom: 0;
	padding-bottom: 0;
}

.pp-ssb-widget {
	width: 100%;
	margin: 0 auto;
	font-family: Sans-serif;
	color: #FFFFFF;
}
body .pp-ssb-widget a.pp-ssb-btn {
	width: 100% !important;
	height: 48px;
	padding: 0;
	color: #FFFFFF;
	display: inline-block;
	margin: 10px 0 10px 0;
	text-decoration: none;
	text-align:left;
	vertical-align: middle;
	line-height: 48px;
	font-size: 90% !important;
	font-weight: bold !important;
	overflow: hidden;
	border-radius: 1px;
	box-shadow: 0 1px 4px rgba(0, 0, 0, 0.2); 
}

body .sidebar .widget .pp-ssb-widget a:link,
body .sidebar .widget .pp-ssb-widget a:visited,
body .sidebar .widget .pp-ssb-widget a:active,
body .sidebar .widget .pp-ssb-widget a:hover,
body .pp-ssb-widget a.pp-ssb-btn:link,
body .pp-ssb-widget a.pp-ssb-btn:visited,
body .pp-ssb-widget a.pp-ssb-btn:active,
body .pp-ssb-widget a.pp-ssb-btn:hover {
	text-decoration: none !important;
	color: #FFFFFF !important;
}
.pp-ssb-widget-dark a,
.pp-ssb-widget-modern a {
	background-color: #222222;
}
.pp-ssb-widget-modern a.pp-ssb-itunes {
	background-color: #732BBE;
}
.pp-ssb-widget-modern a.pp-ssb-email {
	background-color: #337EC9;
}
.pp-ssb-widget-modern a.pp-ssb-stitcher {
	background-color: #197195;
}
.pp-ssb-widget-modern a.pp-ssb-tunein {
	background-color: #2CB6A8;
}
.pp-ssb-widget-modern a.pp-ssb-gp {
	background-color: #F15832;
}
.pp-ssb-widget-modern a.pp-ssb-android {
	background-color: #6AB344;
}
.pp-ssb-widget-modern a.pp-ssb-rss {
	background-color: #FF8800;
}
.pp-ssb-ic {
	width: 48px;
   height: 48px;
	border: 0;
	display: inline-block;
	vertical-align: middle;
	margin-right: 2px;
	background-image: url(http://theredshtick.com/wp-content/plugins/powerpress/images/spriteStandard.png);
	background-repeat: no-repeat;
	background-size: 294px;
}
.pp-ssb-itunes .pp-ssb-ic {
    background-position: -49px 0;
}
.pp-ssb-rss .pp-ssb-ic {
   background-position: 0 -49px;
}
.pp-ssb-email .pp-ssb-ic {
  background-position: -196px -49px;
}
.pp-ssb-android .pp-ssb-ic {
	background-position: -98px -98px;
}
.pp-ssb-stitcher .pp-ssb-ic {
	background-position: -147px -98px;
}
.pp-ssb-tunein .pp-ssb-ic {
	background-position: -245px -98px;
}
.pp-ssb-gp .pp-ssb-ic {
	background-position: -196px -98px;
}

.pp-ssb-more .pp-ssb-ic {
  background-position: -49px -49px;
}
/* Retina-specific stuff here */
@media only screen and (-webkit-min-device-pixel-ratio: 2.0),
       only screen and (min--moz-device-pixel-ratio: 2.0),
       only screen and (-o-min-device-pixel-ratio: 200/100),
       only screen and (min-device-pixel-ratio: 2.0) {
	.pp-sub-ic {
		background-image: url(http://theredshtick.com/wp-content/plugins/powerpress/images/spriteRetina.png);
	}
}
</style>
<meta name="ca_title" content="GUEST COLUMN: &quot;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&quot; — John Kennedy" /><meta name="ca_image" content="http://theredshtick.com/wp-content/uploads/2017/02/Louisiana-Senator-John-Kennedy-heartfelt-150x150.jpg" />

<!-- ngfb meta tags begin -->
<!-- added on 2017-02-07T22:31:53+00:00 -->
<!-- generator:1 --><meta name="generator" content="NGFB Pro 8.39.0-1/L"/>
<!-- generator:2 --><meta name="generator" content="NGFB UM 1.5.14-1/G"/>
<link rel="publisher" href="http://plus.google.com/102895309969016331035/"/>
<link rel="shortlink" href="http://wp.me/p2AWqC-aPL"/>
<meta property="og:url" content="http://theredshtick.com/2017/02/07/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy/"/>
<meta property="og:type" content="article"/>
<!-- article:author:1 --><meta property="article:author" content="https://www.facebook.com/TheRedShtick"/>
<meta property="article:section" content="Satirical"/>
<!-- article:tag:1 --><meta property="article:tag" content="opinion"/>
<!-- article:tag:2 --><meta property="article:tag" content=" politics"/>
<!-- article:tag:3 --><meta property="article:tag" content=" john kennedy"/>
<!-- article:tag:4 --><meta property="article:tag" content=" senator"/>
<!-- article:tag:5 --><meta property="article:tag" content=" fulfills"/>
<!-- article:tag:6 --><meta property="article:tag" content=" louisiana"/>
<!-- article:tag:7 --><meta property="article:tag" content=" religion"/>
<!-- article:tag:8 --><meta property="article:tag" content=" movies"/>
<!-- article:tag:9 --><meta property="article:tag" content=" star trek generations"/>
<!-- article:tag:10 --><meta property="article:tag" content=" nexus"/>
<!-- article:tag:11 --><meta property="article:tag" content=" picard"/>
<!-- article:tag:12 --><meta property="article:tag" content=" kirk"/>
<!-- article:tag:13 --><meta property="article:tag" content=" captain"/>
<!-- article:tag:14 --><meta property="article:tag" content=" burning man"/>
<!-- article:tag:15 --><meta property="article:tag" content=" euphoric"/>
<!-- article:tag:16 --><meta property="article:tag" content=" holy spirit"/>
<!-- article:tag:17 --><meta property="article:tag" content=" whoopi goldberg"/>
<!-- article:tag:18 --><meta property="article:tag" content=" guinan"/>
<!-- article:tag:19 --><meta property="article:tag" content=" joy"/>
<!-- article:tag:20 --><meta property="article:tag" content=" jeff sessions"/>
<!-- article:tag:21 --><meta property="article:tag" content=" attorney general"/>
<!-- article:tag:22 --><meta property="article:tag" content=" josh groban"/>
<!-- article:tag:23 --><meta property="article:tag" content=" music"/>
<!-- article:tag:24 --><meta property="article:tag" content=" zachary"/>
<meta property="article:published_time" content="2017-02-07T16:15:16+00:00"/>
<meta property="article:modified_time" content="2017-02-07T15:20:49+00:00"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:site_name" content="The Red Shtick"/>
<meta property="og:title" content="GUEST COLUMN: &ldquo;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&rdquo; &mdash; John Kennedy"/>
<meta property="og:description" content="I finally made it. I am, at long last, a United States senator, and boy, does it feel dreamy."/>
<meta property="article:publisher" content="http://www.facebook.com/TheRedShtick"/>
<!-- og:image:1 --><meta property="og:image" content="http://theredshtick.com/wp-content/uploads/2017/02/Louisiana-Senator-John-Kennedy-heartfelt-600x315.jpg"/>
<meta name="weibo:article:create_at" content="2017-02-07 16:15:16"/>
<meta name="weibo:article:update_at" content="2017-02-07 15:20:49"/>
<meta name="twitter:domain" content="theredshtick.com"/>
<meta name="twitter:site" content="@redshtick"/>
<meta name="twitter:title" content="GUEST COLUMN: &ldquo;Being a U.S. Senator Completely Fulfills Me in..."/>
<meta name="twitter:description" content="I finally made it. I am, at long last, a United States senator, and boy, does it feel dreamy."/>
<meta name="twitter:creator" content="redshtick"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:image" content="http://theredshtick.com/wp-content/uploads/2017/02/Louisiana-Senator-John-Kennedy-heartfelt-300x169.jpg"/>
<meta itemprop="url" content="http://theredshtick.com/2017/02/07/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy/"/>
<meta itemprop="name" content="GUEST COLUMN: &ldquo;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&rdquo; &mdash; John Kennedy"/>
<noscript itemprop="author" itemscope itemtype="https://schema.org/Person">
	<meta itemprop="name" content="Off the Wire Guest Columnist"/>
	<meta itemprop="image" content="http://www.gravatar.com/avatar/59b6ab5daa928a5e5f0d7b091ef934c4?s=696&amp;d=http%3A%2F%2Ftheredshtick.com%2Fwp-content%2Fuploads%2F2016%2F06%2FRedShtick-TOP-700x667.png"/>
</noscript>
<noscript itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
	<meta itemprop="url" content="http://theredshtick.com/wp-content/uploads/2017/02/Louisiana-Senator-John-Kennedy-heartfelt-696x400.jpg"/>
</noscript>
<!-- ngfb meta tags end -->

<script type="text/javascript" id="ngfb-header-script">
	window.___gcfg = { lang: "en-US" };
	function ngfb_insert_js( script_id, url, async ) {
		if ( document.getElementById( script_id + "-js" ) ) return;
		var async = typeof async !== "undefined" ? async : true;
		var script_pos = document.getElementById( script_id );
		var js = document.createElement( "script" );
		js.id = script_id + "-js";
		js.async = async;
		js.type = "text/javascript";
		js.language = "JavaScript";
		js.src = url;
		script_pos.parentNode.insertBefore( js, script_pos );
	};
</script>
<!-- ngfb header: post buttons are disabled -->
<link rel="icon" href="http://theredshtick.com/wp-content/uploads/2016/04/cropped-RedShtickMan-TOP-667x667-32x32.png" sizes="32x32" />
<link rel="icon" href="http://theredshtick.com/wp-content/uploads/2016/04/cropped-RedShtickMan-TOP-667x667-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://theredshtick.com/wp-content/uploads/2016/04/cropped-RedShtickMan-TOP-667x667-180x180.png" />
<meta name="msapplication-TileImage" content="http://theredshtick.com/wp-content/uploads/2016/04/cropped-RedShtickMan-TOP-667x667-270x270.png" />
<link rel='stylesheet' id='wp_pro_add_style-css'  href='http://theredshtick.com/wp-content/plugins/wp_pro_ad_system/templates/css/wppas.min.css' type='text/css' media='all' />
</head>
<body id="top" class="post-template-default single single-post postid-41649 single-format-standard lazy-enabled">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="http://theredshtick.com/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="http://theredshtick.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Google+" href="https://plus.google.com/102895309969016331035" target="_blank"><i class="fa fa-google-plus"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/TheRedShtick/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/RedShtick" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCxf0phSz48-LYSyKAUU9tNQ" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/the-red-shtick/id561142785?mt=2&#038;ls=1" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/redshtick/" target="_blank"><i class="fa fa-instagram"></i></a><a class="ttip-none" title="Google Play" href="https://goo.gl/app/playmusic?ibi=com.google.PlayMusic&#038;isi=691797987&#038;ius=googleplaymusic&#038;link=https://play.google.com/music/m/Iav2kiscdtsrtrcfeyveu3dzy5y?t%3DThe_Red_Shtick_Podcast" target="_blank"><i class="fa fa-play"></i></a>
			</div>

	
		<div id="mobile-menu"  class="mobile-hide-icons"></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed-all">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

							<span class="today-date">Tue February 7, 2017</span>
				<div class="top-menu"><ul id="menu-top-menu" class="menu"><li id="menu-item-37513" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37513"><a href="http://theredshtick.com/about-us/">About Us</a></li>
<li id="menu-item-37514" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37514"><a href="http://theredshtick.com/advertise/">Advertise</a></li>
<li id="menu-item-37515" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37515"><a href="http://theredshtick.com/contact-us/">Contact Us</a></li>
<li id="menu-item-37516" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37516"><a href="http://theredshtick.com/privacy-policy/">Privacy Policy and User Terms</a></li>
<li id="menu-item-37517" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37517"><a href="http://theredshtick.com/subscribe-to-our-podcasts/">Subscribe to Our Podcasts</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="http://theredshtick.com/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="http://theredshtick.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Google+" href="https://plus.google.com/102895309969016331035" target="_blank"><i class="fa fa-google-plus"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/TheRedShtick/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/RedShtick" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCxf0phSz48-LYSyKAUU9tNQ" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/the-red-shtick/id561142785?mt=2&#038;ls=1" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/redshtick/" target="_blank"><i class="fa fa-instagram"></i></a><a class="ttip-none" title="Google Play" href="https://goo.gl/app/playmusic?ibi=com.google.PlayMusic&#038;isi=691797987&#038;ius=googleplaymusic&#038;link=https://play.google.com/music/m/Iav2kiscdtsrtrcfeyveu3dzy5y?t%3DThe_Red_Shtick_Podcast" target="_blank"><i class="fa fa-play"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo">
			<h2>								<a title="The Red Shtick" href="http://theredshtick.com/">
					<img src="http://theredshtick.com/wp-content/uploads/2016/04/TRS-logo_190x60.png" alt="The Red Shtick" width="190" height="60" /><strong>The Red Shtick The Feistiest Redhead You&#039;ll Meet Online</strong>
				</a>
			</h2>			</div><!-- .logo /-->
<script type="text/javascript">
jQuery(document).ready(function($) {
	var retina = window.devicePixelRatio > 1 ? true : false;
	if(retina) {
       	jQuery('#theme-header .logo img').attr('src',		'http://theredshtick.com/wp-content/uploads/2016/04/TRS-logo_380x120.png');
       	jQuery('#theme-header .logo img').attr('width',		'190');
       	jQuery('#theme-header .logo img').attr('height',	'60');
	}
});
</script>
			<div class="e3lan e3lan-top">			<div  class="paszone_container paszone-container-33788   " id="paszonecont_33788" style="overflow:hidden; max-width:728px; margin: 0 auto; text-align:center;  " ><div class="pasinfotxt above"><small style="font-size:11px; color:#C0C0C0; text-decoration:none;"></small></div><div class="wppaszone proadszone-33788 " id="33788" style="overflow:hidden; width:728px; height:90px; margin: 0 auto; text-align:center; "><div class="wppasrotate rotating_paszone wppasrotate690378893 proadszoneholder-33788" style="" ><div class="pasli pasli-33801 "   duration="15000" bid="33801" aid="33788"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- TRS-Sitewide Header Leaderboard 728x90 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6698439191164571"
     data-ad-slot="5474472336"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div class="pasli pasli-33796 "   duration="15000" bid="33796" aid="33788"><a class="wpproaddlink" href="http://theredshtick.com?pasID=MzM3OTY=&amp;pasZONE=MzM3ODg=" target="_blank" ><img src="http://theredshtick.com/wp-content/uploads/2015/07/GCF-TRS_728x90.png?pas=11773820681702072231" alt="GCF: Athlete in You 728&#215;90" border="0"  /></a></div><div class="pasli pasli-33802 "   duration="15000" bid="33802" aid="33788"><a class="wpproaddlink" href="http://theredshtick.com?pasID=MzM4MDI=&amp;pasZONE=MzM3ODg=" target="_blank" rel="nofollow"><img src="http://theredshtick.com/wp-content/uploads/2015/07/ElRio-728x90-APR13.png?pas=11083929751702072231" alt="El Rio 728&#215;90 map background" border="0"  /></a></div></div></div></div><script type="text/javascript">jQuery(window).load(function(){jQuery(function($){var slider_wppasrotate690378893 = $(".wppasrotate690378893").bxSlider({ mode: "fade",slideMargin: 5,autoHover: true,adaptiveHeight: true,pager: false,controls: false,auto: true,pause: $(".wppasrotate690378893").find(".pasli").first().attr("duration"),preloadImages: "all",onSliderLoad: function(currentIndex){ $(".wppasrotate690378893").find(".pasli").css("visibility", "visible");},onSlideAfter: function( $slideElement, oldIndex, newIndex ){ slider_wppasrotate690378893.setPause($($slideElement).attr("duration"));},});});});</script>				</div>			<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

									<a class="main-nav-logo" title="The Red Shtick" href="http://theredshtick.com/">
						<img src="http://theredshtick.com/wp-content/uploads/2016/04/TRS-menu-logo.png" width="195" height="54" alt="The Red Shtick">
					</a>
				
					<div class="main-menu"><ul id="menu-main-navigation" class="menu"><li id="menu-item-37450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-37450"><a href="http://theredshtick.com">Home</a></li>
<li id="menu-item-23229" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-23229 mega-menu mega-recent-featured "><a target="_blank" href="http://theredshtick.com/category/articles/newsish/">Newsish</a>
<div class="mega-menu-block menu-sub-content">

<ul class="mega-recent-featured-list sub-list">
	<li id="menu-item-23230" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-23230"><a target="_blank" href="http://theredshtick.com/category/articles/newsish/off-the-wire/">Off the Wire</a></li>
	<li id="menu-item-23231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23231"><a target="_blank" href="http://theredshtick.com/category/breaking-news/">Breaking News</a></li>
	<li id="menu-item-23232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23232"><a target="_blank" href="http://theredshtick.com/category/breaking-news/corrections/">Corrections</a></li>
</ul>

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/07/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy/" title="GUEST COLUMN: &#8220;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&#8221; — John Kennedy"><img src="http://theredshtick.com/wp-content/uploads/2017/02/Louisiana-Senator-John-Kennedy-heartfelt-660x330.jpg" width="660" height="330" alt="GUEST COLUMN: &#8220;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&#8221; — John Kennedy" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/07/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy/" title="GUEST COLUMN: &#8220;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&#8221; — John Kennedy">GUEST COLUMN: &#8220;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&#8221; — John Kennedy</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>6 hours ago</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/06/islamic-state-reaffirms-desire-to-kill-all-humanity-not-just-americans-despite-trumps-provocations/" title="Islamic State Reaffirms Desire to Kill All Humanity, Not Just Americans, Despite Trump&#8217;s Provocations"><img src="http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump.jpg" width="110" height="75" alt="Islamic State Reaffirms Desire to Kill All Humanity, Not Just Americans, Despite Trump&#8217;s Provocations" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/06/islamic-state-reaffirms-desire-to-kill-all-humanity-not-just-americans-despite-trumps-provocations/" title="Islamic State Reaffirms Desire to Kill All Humanity, Not Just Americans, Despite Trump&#8217;s Provocations">Islamic State Reaffirms Desire to Kill All Humanity, Not Just Americans, Despite Trump&#8217;s Provocations</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>1 day ago</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/03/kellyanne-conway-the-press-refuses-to-cover-that-thing-i-just-made-up/" title="Kellyanne Conway: &#8220;The Press Refuses to Cover That Thing I Just Made Up&#8221;"><img src="http://theredshtick.com/wp-content/uploads/2017/02/Kellyanne-Conway-110x75.jpg" width="110" height="75" alt="Kellyanne Conway: &#8220;The Press Refuses to Cover That Thing I Just Made Up&#8221;" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/03/kellyanne-conway-the-press-refuses-to-cover-that-thing-i-just-made-up/" title="Kellyanne Conway: &#8220;The Press Refuses to Cover That Thing I Just Made Up&#8221;">Kellyanne Conway: &#8220;The Press Refuses to Cover That Thing I Just Made Up&#8221;</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>4 days ago</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/02/lsu-gordon-mckernan-agree-to-double-font-size-of-g-in-tigers/" title="LSU, Gordon McKernan Agree to Double Font Size of ‘G’ in Tigers"><img src="http://theredshtick.com/wp-content/uploads/2017/01/LSU_Tiger_Stadium-Double-sized-G-110x75.png" width="110" height="75" alt="LSU, Gordon McKernan Agree to Double Font Size of ‘G’ in Tigers" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/02/lsu-gordon-mckernan-agree-to-double-font-size-of-g-in-tigers/" title="LSU, Gordon McKernan Agree to Double Font Size of ‘G’ in Tigers">LSU, Gordon McKernan Agree to Double Font Size of ‘G’ in Tigers</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>5 days ago</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-23097" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-23097 mega-menu mega-recent-featured "><a target="_blank" href="http://theredshtick.com/category/articles/opinion/">Opinion</a>
<div class="mega-menu-block menu-sub-content">

<ul class="mega-recent-featured-list sub-list">
	<li id="menu-item-23061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23061"><a target="_blank" href="http://theredshtick.com/category/articles/opinion/from-the-publisher/">From the Publisher</a></li>
	<li id="menu-item-23062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23062"><a target="_blank" href="http://theredshtick.com/category/articles/opinion/hero-highlight/">Hero Highlight</a></li>
	<li id="menu-item-23069" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23069"><a target="_blank" href="http://theredshtick.com/category/articles/opinion/sphincter-spotlight/">Sphincter Spotlight</a></li>
</ul>

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/26/we-shall-overcomb-trumps-hair-belies-lies/" title="We Shall Overcomb: Trump&#8217;s Hair Belies Lies"><img src="http://theredshtick.com/wp-content/uploads/2017/01/Donald-Trump-hair_comb-over-orange-660x330.jpg" width="660" height="330" alt="We Shall Overcomb: Trump&#8217;s Hair Belies Lies" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/26/we-shall-overcomb-trumps-hair-belies-lies/" title="We Shall Overcomb: Trump&#8217;s Hair Belies Lies">We Shall Overcomb: Trump&#8217;s Hair Belies Lies</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>2 weeks ago</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/09/sphincter-spotlight-the-guy-trying-to-ruin-doug-welborns-birthdays-with-a-lawsuit/" title="SPHINCTER SPOTLIGHT: The Guy Trying to Ruin Doug Welborn&#8217;s Birthdays With a Lawsuit"><img src="http://theredshtick.com/wp-content/uploads/2015/11/EBR-Clerk-Court-Doug-Welborn-e1446820137436.jpg" width="110" height="75" alt="SPHINCTER SPOTLIGHT: The Guy Trying to Ruin Doug Welborn&#8217;s Birthdays With a Lawsuit" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/09/sphincter-spotlight-the-guy-trying-to-ruin-doug-welborns-birthdays-with-a-lawsuit/" title="SPHINCTER SPOTLIGHT: The Guy Trying to Ruin Doug Welborn&#8217;s Birthdays With a Lawsuit">SPHINCTER SPOTLIGHT: The Guy Trying to Ruin Doug Welborn&#8217;s Birthdays With a Lawsuit</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>4 weeks ago</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/02/guaranty-broadcasting-sues-morning-show-duo-for-cancelling-delivery-of-totally-not-lame-jokes/" title="Guaranty Broadcasting Sues Morning Show Duo for Cancelling Delivery of Totally Not Lame Jokes"><img src="http://theredshtick.com/wp-content/uploads/2017/01/Walton-And-Johnson-e1483305835448-110x75.jpg" width="110" height="75" alt="Guaranty Broadcasting Sues Morning Show Duo for Cancelling Delivery of Totally Not Lame Jokes" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/02/guaranty-broadcasting-sues-morning-show-duo-for-cancelling-delivery-of-totally-not-lame-jokes/" title="Guaranty Broadcasting Sues Morning Show Duo for Cancelling Delivery of Totally Not Lame Jokes">Guaranty Broadcasting Sues Morning Show Duo for Cancelling Delivery of Totally Not Lame Jokes</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 2, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/11/23/hero-highlight-jim-berrigan-champion-of-transparency/" title="HERO HIGHLIGHT: Jim Berrigan — Champion of Transparency"><img src="http://theredshtick.com/wp-content/uploads/2016/11/Jim-Berrigan-Louisiana-Glass-e1479857906363-110x75.jpeg" width="110" height="75" alt="HERO HIGHLIGHT: Jim Berrigan — Champion of Transparency" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/11/23/hero-highlight-jim-berrigan-champion-of-transparency/" title="HERO HIGHLIGHT: Jim Berrigan — Champion of Transparency">HERO HIGHLIGHT: Jim Berrigan — Champion of Transparency</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>November 23, 2016</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-23098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23098 mega-menu mega-recent-featured "><a target="_blank" href="http://theredshtick.com/category/articles/your-views/">Your Views</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/24/your-voices-tiger-stadium-broken-into-three-times-this-month-what-say-you/" title="YOUR VOICES: Tiger Stadium Broken Into Three Times This Month. What Say You?"><img src="http://theredshtick.com/wp-content/uploads/2016/10/Your-voices-Asian-woman-sidewalk-660x330.jpg" width="660" height="330" alt="YOUR VOICES: Tiger Stadium Broken Into Three Times This Month. What Say You?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/24/your-voices-tiger-stadium-broken-into-three-times-this-month-what-say-you/" title="YOUR VOICES: Tiger Stadium Broken Into Three Times This Month. What Say You?">YOUR VOICES: Tiger Stadium Broken Into Three Times This Month. What Say You?</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>2 weeks ago</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/10/26/your-voices-andre-moreau-claims-hes-mr-baton-rouge-what-say-you/" title="YOUR VOICES: Andre Moreau Claims He&#8217;s &#8220;Mr. Baton Rouge.&#8221; What Say You?"><img src="http://theredshtick.com/wp-content/uploads/2016/10/Your-voices-bald-man-suit-e1476296366334-110x75.jpg" width="110" height="75" alt="YOUR VOICES: Andre Moreau Claims He&#8217;s &#8220;Mr. Baton Rouge.&#8221; What Say You?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/10/26/your-voices-andre-moreau-claims-hes-mr-baton-rouge-what-say-you/" title="YOUR VOICES: Andre Moreau Claims He&#8217;s &#8220;Mr. Baton Rouge.&#8221; What Say You?">YOUR VOICES: Andre Moreau Claims He&#8217;s &#8220;Mr. Baton Rouge.&#8221; What Say You?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 26, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/10/13/your-voices-lsus-mike-vi-died-after-a-bout-with-cancer-what-say-you/" title="YOUR VOICES: LSU&#8217;s Mike VI Died After a Bout With Cancer. What Say You?"><img src="http://theredshtick.com/wp-content/uploads/2016/10/Your-voices-bald-man-suit-e1476296366334-110x75.jpg" width="110" height="75" alt="YOUR VOICES: LSU&#8217;s Mike VI Died After a Bout With Cancer. What Say You?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/10/13/your-voices-lsus-mike-vi-died-after-a-bout-with-cancer-what-say-you/" title="YOUR VOICES: LSU&#8217;s Mike VI Died After a Bout With Cancer. What Say You?">YOUR VOICES: LSU&#8217;s Mike VI Died After a Bout With Cancer. What Say You?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 13, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/07/30/your-voices-donald-trump-invited-russia-to-hack-the-u-s-what-say-you/" title="YOUR VOICES: Donald Trump Invited Russia to Hack the U.S. What Say You?"><img src="http://theredshtick.com/wp-content/uploads/2014/05/Woman-sunglasses-YourVoices-wide.jpg" width="110" height="75" alt="YOUR VOICES: Donald Trump Invited Russia to Hack the U.S. What Say You?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/07/30/your-voices-donald-trump-invited-russia-to-hack-the-u-s-what-say-you/" title="YOUR VOICES: Donald Trump Invited Russia to Hack the U.S. What Say You?">YOUR VOICES: Donald Trump Invited Russia to Hack the U.S. What Say You?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 30, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/07/12/your-voices-police-arrested-scores-of-people-protesting-alton-sterlings-killing-what-say-you/" title="YOUR VOICES: Police Arrested Scores of People Protesting Alton Sterling&#8217;s Killing. What Say You?"><img src="http://theredshtick.com/wp-content/uploads/2013/12/WhiteSuit-man-YourVoices-wide.png" width="110" height="75" alt="YOUR VOICES: Police Arrested Scores of People Protesting Alton Sterling&#8217;s Killing. What Say You?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/07/12/your-voices-police-arrested-scores-of-people-protesting-alton-sterlings-killing-what-say-you/" title="YOUR VOICES: Police Arrested Scores of People Protesting Alton Sterling&#8217;s Killing. What Say You?">YOUR VOICES: Police Arrested Scores of People Protesting Alton Sterling&#8217;s Killing. What Say You?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>July 12, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/06/28/your-voices-wal-mart-is-offering-curbside-pickup-at-some-area-stores-what-say-you/" title="YOUR VOICES: Wal-Mart Is Offering Curbside Pickup at Some Area Stores. What Say You?"><img src="http://theredshtick.com/wp-content/uploads/2014/05/Your-Voices-Goatee-Man-wide.jpg" width="110" height="75" alt="YOUR VOICES: Wal-Mart Is Offering Curbside Pickup at Some Area Stores. What Say You?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/06/28/your-voices-wal-mart-is-offering-curbside-pickup-at-some-area-stores-what-say-you/" title="YOUR VOICES: Wal-Mart Is Offering Curbside Pickup at Some Area Stores. What Say You?">YOUR VOICES: Wal-Mart Is Offering Curbside Pickup at Some Area Stores. What Say You?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>June 28, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/05/23/your-voices-mayor-kip-holden-is-running-for-congress-what-say-you/" title="YOUR VOICES: Mayor Kip Holden is Running for Congress. What Say You?"><img src="http://theredshtick.com/wp-content/uploads/2014/05/Woman-sunglasses-YourVoices-wide.jpg" width="110" height="75" alt="YOUR VOICES: Mayor Kip Holden is Running for Congress. What Say You?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/05/23/your-voices-mayor-kip-holden-is-running-for-congress-what-say-you/" title="YOUR VOICES: Mayor Kip Holden is Running for Congress. What Say You?">YOUR VOICES: Mayor Kip Holden is Running for Congress. What Say You?</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>May 23, 2016</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-23096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-23096 mega-menu mega-recent-featured "><a target="_blank" href="http://theredshtick.com/category/articles/lagniappe/">Lagniappe</a>
<div class="mega-menu-block menu-sub-content">

<ul class="mega-recent-featured-list sub-list">
	<li id="menu-item-23060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23060"><a target="_blank" href="http://theredshtick.com/category/articles/lagniappe/features/">Features</a></li>
	<li id="menu-item-36736" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36736"><a href="http://theredshtick.com/category/articles/lagniappe/rejected-ask-the-advocate/">Rejected Ask the Advocate</a></li>
	<li id="menu-item-36737" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36737"><a href="http://theredshtick.com/category/articles/lagniappe/shtickbait/">Shtickbait</a></li>
	<li id="menu-item-26023" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26023"><a target="_blank" href="http://theredshtick.com/category/articles/quizzes/">Quizzes</a></li>
	<li id="menu-item-27469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27469"><a target="_blank" href="http://theredshtick.com/category/articles/war-for-st-george/">War for St. George</a></li>
	<li id="menu-item-23116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23116"><a target="_blank" href="http://theredshtick.com/category/articles/lagniappe/bacs/">BACS</a></li>
	<li id="menu-item-27468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27468"><a target="_blank" href="http://theredshtick.com/category/articles/lagniappe/march-madness/">March Madness</a></li>
	<li id="menu-item-27298" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27298"><a target="_blank" href="http://theredshtick.com/category/articles/lagniappe/overrated-rouge/">Overrated Rouge</a></li>
</ul>

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/20/the-red-shtick-investigates-what-happened-to-the-red-stick-bicentennial-mascot/" title="The Red Shtick Investigates: What Happened to the Red Stick Bicentennial Mascot?"><img src="http://theredshtick.com/wp-content/uploads/2016/11/Red-Stick-bicentennial-mascot-sticky-e1480522916447-660x330.jpg" width="660" height="330" alt="The Red Shtick Investigates: What Happened to the Red Stick Bicentennial Mascot?" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/20/the-red-shtick-investigates-what-happened-to-the-red-stick-bicentennial-mascot/" title="The Red Shtick Investigates: What Happened to the Red Stick Bicentennial Mascot?">The Red Shtick Investigates: What Happened to the Red Stick Bicentennial Mascot?</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>3 weeks ago</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/05/10-gumbos-that-are-totally-losing-their-shit/" title="10 Gumbos That Are Totally Losing Their Shit"><img src="http://theredshtick.com/wp-content/uploads/2017/01/Boiling-gumbo-110x75.jpg" width="110" height="75" alt="10 Gumbos That Are Totally Losing Their Shit" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/05/10-gumbos-that-are-totally-losing-their-shit/" title="10 Gumbos That Are Totally Losing Their Shit">10 Gumbos That Are Totally Losing Their Shit</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 5, 2017</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/12/15/ask-a-conspiracy-theorist-my-friend-is-dead-or-is-he/" title="Ask a Conspiracy Theorist: &#8220;My Friend Is Dead. Or Is He?&#8221;"><img src="http://theredshtick.com/wp-content/uploads/2016/12/Conspiracy-theorist-tinfoil-hat-110x75.jpg" width="110" height="75" alt="Ask a Conspiracy Theorist: &#8220;My Friend Is Dead. Or Is He?&#8221;" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/12/15/ask-a-conspiracy-theorist-my-friend-is-dead-or-is-he/" title="Ask a Conspiracy Theorist: &#8220;My Friend Is Dead. Or Is He?&#8221;">Ask a Conspiracy Theorist: &#8220;My Friend Is Dead. Or Is He?&#8221;</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 15, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/12/14/global-warming-fixed-donald-trump-to-make-christmas-extra-white-for-years-to-come/" title="Global Warming Fixed: Donald Trump to Make Christmas Extra-White for Years to Come!"><img src="http://theredshtick.com/wp-content/uploads/2016/12/Trump-Santa-e1481654054599-110x75.jpg" width="110" height="75" alt="Global Warming Fixed: Donald Trump to Make Christmas Extra-White for Years to Come!" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/12/14/global-warming-fixed-donald-trump-to-make-christmas-extra-white-for-years-to-come/" title="Global Warming Fixed: Donald Trump to Make Christmas Extra-White for Years to Come!">Global Warming Fixed: Donald Trump to Make Christmas Extra-White for Years to Come!</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 14, 2016</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-36601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-36601 mega-menu mega-recent-featured "><a target="_blank" href="http://theredshtick.com/category/articles/columns/">Columns</a>
<div class="mega-menu-block menu-sub-content">

<ul class="mega-recent-featured-list sub-list">
	<li id="menu-item-23108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23108"><a target="_blank" href="http://theredshtick.com/category/articles/columns/horrorscopes/">Horrorscopes</a></li>
	<li id="menu-item-28339" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28339"><a target="_blank" href="http://theredshtick.com/category/articles/columns/jedophilia/">Jedophilia</a></li>
	<li id="menu-item-36610" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36610"><a target="_blank" href="http://theredshtick.com/category/articles/columns/reel-dirt/">Reel Dirt</a></li>
	<li id="menu-item-40853" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40853"><a target="_blank" href="http://theredshtick.com/category/articles/columns/mental-vacation/">Mental Vacation</a></li>
	<li id="menu-item-23059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23059"><a target="_blank" href="http://theredshtick.com/category/articles/columns/curran-events/">Curran Events</a></li>
	<li id="menu-item-36611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36611"><a target="_blank" href="http://theredshtick.com/category/articles/archived-columns/">Archived Columns</a></li>
</ul>

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/10/horrorscopes-make-the-year-a-better-place/" title="HORRORSCOPES: Make the Year a Better Place"><img src="http://theredshtick.com/wp-content/uploads/2017/01/Be-More-Awesome-e1484001421458-660x330.jpg" width="660" height="330" alt="HORRORSCOPES: Make the Year a Better Place" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/10/horrorscopes-make-the-year-a-better-place/" title="HORRORSCOPES: Make the Year a Better Place">HORRORSCOPES: Make the Year a Better Place</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>4 weeks ago</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/12/29/2016-um-yeah/" title="2016&#8230; Um&#8230; Yeah."><img src="http://theredshtick.com/wp-content/uploads/2016/12/Celebrity-deaths-2016-110x75.jpg" width="110" height="75" alt="2016&#8230; Um&#8230; Yeah." /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/12/29/2016-um-yeah/" title="2016&#8230; Um&#8230; Yeah.">2016&#8230; Um&#8230; Yeah.</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 29, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/12/07/white-louisiana-man-comes-out-admits-to-voting-for-hillary-clinton/" title="White Louisiana Man Comes Out, Admits to Voting for Hillary Clinton"><img src="http://theredshtick.com/wp-content/uploads/2016/11/man_silhouette_headshot-e1480517771489-110x75.jpg" width="110" height="75" alt="White Louisiana Man Comes Out, Admits to Voting for Hillary Clinton" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/12/07/white-louisiana-man-comes-out-admits-to-voting-for-hillary-clinton/" title="White Louisiana Man Comes Out, Admits to Voting for Hillary Clinton">White Louisiana Man Comes Out, Admits to Voting for Hillary Clinton</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 7, 2016</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2016/12/01/a-red-sticky-situation/" title="A Red Sticky Situation"><img src="http://theredshtick.com/wp-content/uploads/2016/11/Red-Stick-bicentennial-mascot-sticky-e1480522916447-110x75.jpg" width="110" height="75" alt="A Red Sticky Situation" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2016/12/01/a-red-sticky-situation/" title="A Red Sticky Situation">A Red Sticky Situation</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>December 1, 2016</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-23072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-23072 mega-menu mega-recent-featured "><a target="_blank" href="http://theredshtick.com/category/podcast/">Podcasts</a>
<div class="mega-menu-block menu-sub-content">

<ul class="mega-recent-featured-list sub-list">
	<li id="menu-item-23076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23076"><a target="_blank" href="http://theredshtick.com/category/podcast/the-red-shtick-podcast/">The Red Shtick Podcast</a></li>
	<li id="menu-item-23074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23074"><a target="_blank" href="http://theredshtick.com/category/podcast/dorque-podcast/">Dorque</a></li>
	<li id="menu-item-36900" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36900"><a target="_blank" href="http://theredshtick.com/category/podcast/there-can-be-only-one/">There Can Be Only One</a></li>
	<li id="menu-item-23075" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23075"><a target="_blank" href="http://theredshtick.com/category/podcast/the-family-dinner-podcast/">The Family Dinner Podcast</a></li>
	<li id="menu-item-29082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29082"><a target="_blank" href="http://theredshtick.com/category/podcast/bicoastal-hootenanny/">Bicoastal Hootenanny</a></li>
	<li id="menu-item-30776" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30776"><a target="_blank" href="http://theredshtick.com/subscribe-to-our-podcasts/">Subscribe to Our Podcasts</a></li>
</ul>

<div class="mega-menu-content">
<div class="mega-recent-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/03/there-can-be-only-one-the-podcast-43-standoff/" title="There Can Be Only One – The Podcast 43: &#8220;Standoff&#8221;"><img src="http://theredshtick.com/wp-content/uploads/2017/02/standOffPoster.jpg" width="660" height="330" alt="There Can Be Only One – The Podcast 43: &#8220;Standoff&#8221;" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/03/there-can-be-only-one-the-podcast-43-standoff/" title="There Can Be Only One – The Podcast 43: &#8220;Standoff&#8221;">There Can Be Only One – The Podcast 43: &#8220;Standoff&#8221;</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>4 days ago</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/02/the-red-shtick-podcast-episode-215-pedophiles-can-own-dogs-too/" title="The Red Shtick Podcast, Episode 215: &#8220;Pedophiles Can Own Dogs, Too&#8221;"><img src="http://theredshtick.com/wp-content/uploads/2017/02/Ascension-Parish_missing-dog-110x75.jpg" width="110" height="75" alt="The Red Shtick Podcast, Episode 215: &#8220;Pedophiles Can Own Dogs, Too&#8221;" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/02/the-red-shtick-podcast-episode-215-pedophiles-can-own-dogs-too/" title="The Red Shtick Podcast, Episode 215: &#8220;Pedophiles Can Own Dogs, Too&#8221;">The Red Shtick Podcast, Episode 215: &#8220;Pedophiles Can Own Dogs, Too&#8221;</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>5 days ago</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/01/dorque-episode-139-thats-news-to-me/" title="Dorque, Episode 139: That&#8217;s News to Me"><img src="http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400.png" width="110" height="75" alt="Dorque, Episode 139: That&#8217;s News to Me" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/02/01/dorque-episode-139-thats-news-to-me/" title="Dorque, Episode 139: That&#8217;s News to Me">Dorque, Episode 139: That&#8217;s News to Me</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>6 days ago</span></li><li><div class="post-thumbnail"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/27/there-can-be-only-one-the-podcast-42-split/" title="There Can Be Only One – The Podcast 42: &#8220;Split&#8221;"><img src="http://theredshtick.com/wp-content/uploads/2017/01/splitPoster-110x75.jpg" width="110" height="75" alt="There Can Be Only One – The Podcast 42: &#8220;Split&#8221;" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://theredshtick.com/2017/01/27/there-can-be-only-one-the-podcast-42-split/" title="There Can Be Only One – The Podcast 42: &#8220;Split&#8221;">There Can Be Only One – The Podcast 42: &#8220;Split&#8221;</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>2 weeks ago</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-23243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23243"><a target="_blank" href="http://eepurl.com/nRja9">Shtick in the Box (Weekly Update)</a></li>
<li id="menu-item-23120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23120"><a>Partners</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-23123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23123"><a target="_blank" href="http://thedeadpelican.com">The Dead Pelican</a></li>
	<li id="menu-item-26252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26252"><a target="_blank" href="http://humorfeed.com/">HumorFeed</a></li>
	<li id="menu-item-37444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37444"><a target="_blank" href="http://modernliberals.com/">Modern Liberals</a></li>
	<li id="menu-item-31314" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-31314"><a target="_blank" href="http://www.talk1073.com/home/">Talk 107.3</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-31317" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31317"><a target="_blank" href="http://player.tritondigital.com/8091">Listen Live</a></li>
	</ul>
</li>
	<li id="menu-item-31315" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-31315"><a target="_blank" href="http://www.eagle981.com/home/">Eagle 98.1</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-31316" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-31316"><a target="_blank" href="http://player.tritondigital.com/8101">Listen Live</a></li>
	</ul>
</li>
	<li id="menu-item-28980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-28980"><a target="_blank" href="http://www.classichits1033.com/">Classic Hits 103.3</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-28981" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28981"><a target="_blank" href="http://player.listenlive.co/22661">Listen Live</a></li>
	</ul>
</li>
	<li id="menu-item-23122" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23122"><a target="_blank" href="http://www.facebook.com/familydinnerimprov">The Family Dinner</a></li>
	<li id="menu-item-23124" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23124"><a target="_blank" href="http://www.facebook.com/pages/Delete-Comedy/353220574693778">Delete Comedy</a></li>
</ul>
</li>
</ul></div>										<a href="http://theredshtick.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a>
					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

		
	<div class="clear"></div>
	<div id="breaking-news" class="breaking-news">
		<span class="breaking-news-title"><i class="fa fa-bolt"></i> <span>News Shticker</span></span>
		
					<ul>
					<li><a href="http://theredshtick.com/2017/02/05/source-trump-considering-drafting-executive-order-declaring-patriots-super-bowl-champions/" title="SOURCE: Trump considering drafting executive order declaring Patriots Super Bowl champions.">SOURCE: Trump considering drafting executive order declaring Patriots Super Bowl champions.</a></li>
					<li><a href="http://theredshtick.com/2017/02/02/health-new-fda-guideline-calls-for-four-daily-servings-of-word-salad/" title="HEALTH: New FDA guideline calls for four daily servings of word salad.">HEALTH: New FDA guideline calls for four daily servings of word salad.</a></li>
					<li><a href="http://theredshtick.com/2017/02/02/correction-president-trump-did-not-see-his-shadow-this-morning-it-was-just-steve-bannon/" title="CORRECTION: President Trump did not see his shadow this morning. It was just Steve Bannon.">CORRECTION: President Trump did not see his shadow this morning. It was just Steve Bannon.</a></li>
					<li><a href="http://theredshtick.com/2017/02/01/international-trump-administration-puts-iran-on-double-secret-probation/" title="INTERNATIONAL: Trump administration puts Iran on double-secret probation.">INTERNATIONAL: Trump administration puts Iran on double-secret probation.</a></li>
					<li><a href="http://theredshtick.com/2017/01/31/politics-right-wing-conspiracy-theorists-call-trumps-putin-ties-double-reverse-flea-flicker-trickeration-red-flag-false-conspiracy/" title="POLITICS: Right-wing conspiracy theorists call Trump&#8217;s Putin ties &#8220;double-reverse, flea-flicker trickeration red-flag false conspiracy.&#8221;">POLITICS: Right-wing conspiracy theorists call Trump&#8217;s Putin ties &#8220;double-reverse, flea-flicker trickeration red-flag false conspiracy.&#8221;</a></li>
					<li><a href="http://theredshtick.com/2017/01/30/breaking-acting-attorney-general-refuses-to-defend-the-indefensible/" title="BREAKING: Acting Attorney General refuses to defend the indefensible.">BREAKING: Acting Attorney General refuses to defend the indefensible.</a></li>
					<li><a href="http://theredshtick.com/2017/01/30/source-national-archives-to-preserve-president-steve-bannons-used-mcgriddle-wrappers/" title="SOURCE: National Archives to preserve President Steve Bannon&#8217;s used McGriddle wrappers.">SOURCE: National Archives to preserve President Steve Bannon&#8217;s used McGriddle wrappers.</a></li>
					<li><a href="http://theredshtick.com/2017/01/30/breaking-radical-muslims-attempt-to-intimidate-rural-christians-by-leaving-veggie-tray-toothbrushes-at-local-church/" title="BREAKING: Radical Muslims attempt to intimidate rural Christians by leaving veggie tray, toothbrushes at local church.">BREAKING: Radical Muslims attempt to intimidate rural Christians by leaving veggie tray, toothbrushes at local church.</a></li>
					<li><a href="http://theredshtick.com/2017/01/28/breaking-christian-nation-demands-middle-eastern-children-die-for-its-sins/" title="BREAKING: &#8220;Christian&#8221; nation demands Middle Eastern children die for its sins.">BREAKING: &#8220;Christian&#8221; nation demands Middle Eastern children die for its sins.</a></li>
					<li><a href="http://theredshtick.com/2017/01/24/politics-burger-king-sues-trump-administration-claims-white-house-infringing-on-trademarked-home-of-the-whopper-slogan/" title="POLITICS: Burger King sues Trump administration, claims White House infringing on trademarked &#8220;Home of the Whopper&#8221; slogan.">POLITICS: Burger King sues Trump administration, claims White House infringing on trademarked &#8220;Home of the Whopper&#8221; slogan.</a></li>
					</ul>
					
		
		<script type="text/javascript">
			jQuery(document).ready(function(){
								jQuery('#breaking-news ul').innerFade({animationType: 'slide', speed: 750 , timeout: 5236});
							});
					</script>
	</div> <!-- .breaking-news -->

	
	<div id="main-content" class="container">
	
	
	
	
	
	<div class="content">

		
		
		

		
		<article class="post-listing post-41649 post type-post status-publish format-standard has-post-thumbnail  category-off-the-wire tag-current-events tag-movies-tv tag-opinion tag-politics tag-religion" id="the-post">
			
			<div class="single-post-thumb">
			<img width="660" height="330" src="http://theredshtick.com/wp-content/uploads/2017/02/Louisiana-Senator-John-Kennedy-heartfelt-660x330.jpg" class="attachment-slider size-slider wp-post-image" alt="" data-wp-pid="41650" />		</div>
	
		


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">GUEST COLUMN: &#8220;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&#8221; — John Kennedy</span></h1>

						
<p class="post-meta">
		
	<span class="post-meta-author"><i class="fa fa-user"></i><a href="http://theredshtick.com/author/guest-columnist/" title="">Off the Wire Guest Columnist </a></span>
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>6 hours ago</span>	
	<span class="post-cats"><i class="fa fa-folder"></i><a href="http://theredshtick.com/category/articles/newsish/off-the-wire/" rel="category tag">Off the Wire</a></span>
	
</p>
<div class="clear"></div>
			
				<div class="entry">
					
					
					<p><img class="alignright size-full wp-image-261" src="http://theredshtick.com/wp-content/uploads/2012/06/TRS_OTW.png" alt="Off the Wire" width="75" height="300">It took two party affiliations and three campaigns against three different opponents, but I finally made it. I am, at long last, a United States senator, and boy, does it feel dreamy.</p>
<p>I&#8217;ll be honest: I was worried it might not be all what it&#8217;s cracked up to be. I was like, &#8220;What if it&#8217;s a let-down after working so hard to get there?&#8221;&nbsp;</p>
<p>Well, let me tell you: Being a U.S. senator completely fulfills me in every way imaginable. Physically. Emotionally. Spiritually. You name it.</p>
<p>Now, I know some folks will say, &#8220;But what about your family? What about your faith? Being senator couldn&#8217;t be more fulfilling than having a loving, supportive family and serving a powerful, forgiving God. Right?&#8221;</p>
<p>Wrong! Have you ever been a U.S. senator? If not, you have no idea what it&#8217;s like!</p><div  class="paszone_container paszone-container-38668  center_pas " id="paszonecont_38668" style="overflow:hidden;  text-align:center;  " ><div class="pasinfotxt above"><small style="font-size:11px; color:#C0C0C0; text-decoration:none;"></small></div><div class="wppaszone proadszone-38668 " id="38668" style="overflow:hidden;  width:100%; height:auto;  text-align:center; "><div class="wppasrotate   proadszoneholder-38668" style="" ><div class="pasli pasli-38666 "   duration="5000" bid="38666" aid="38668"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Mobile-Desktop Content -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6698439191164571"
     data-ad-slot="3403005936"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div></div>
<blockquote><p><strong>Do you have any idea what it’s like to be able to look lovingly at Jeff Sessions and bat my brown, puppy dog eyes at him in admiration while telling him how awesome he is?</strong></p></blockquote>
<p>Seriously, it&#8217;s hard to describe how incredibly euphoric it is being a part of the upper house of the legislative branch of the federal government of the most powerful country on Earth. I&#8217;ve heard people talk about how they feel when the Holy Spirit takes over their bodies when they speak in tongues, or how people who go to Burning Man feel like they are one with the entire universe. It&#8217;s like that all the time for me now that I&#8217;m a U.S. senator.</p>
<p>Remember that movie <em>Star Trek: Generations</em>, the one with Captains Picard and Kirk? They had the Nexus, an extra-dimensional realm where everything was so perfect and fulfilling that you never wanted to leave. Remember? Whoopi Goldberg&#8217;s character Guinan described it like this: &#8220;It was like being inside joy. As if joy were something tangible, and you could wrap yourself up in it like a blanket.&#8221;</p>
<p>That! That right there! That is exactly how being in the U.S. Senate is!</p>
<p>No wonder no one ever wants to leave this place! It&#8217;s like being in the Nexus, except you don&#8217;t have to blow up a sun to get in! But even if you did need to destroy an entire solar system to be elected, it would absolutely be worth the effort and sacrifice.<br />

<div id="contentad310958"></div>

To be afforded the opportunity to sit in on the committee confirmation hearings for our next attorney general is the kind of stuff I had wet dreams about when I was just a boy growing up in Zachary.&nbsp;Do you have any idea what it&#8217;s like to be able to look lovingly at Jeff Sessions and bat my brown, puppy dog eyes at him in admiration while telling him how awesome he is? And then to have him smile and nod back at me? My God, it&#8217;s like I&#8217;ve died and gone to heaven.</p>
<p>To quote Josh Groban, &#8220;I am filled with wonder. Sometimes, I think I glimpse eternity.&#8221;<img class="alignright size-full wp-image-296" src="http://theredshtick.com/wp-content/uploads/2012/06/RedShtickTop-ColumnStop.png" alt="" width="14" height="30" data-wp-pid="296"></p>
<p>&nbsp;</p>
<div id="contentad36433"></div>
</p><!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ --><h3>What Do You Think Of This Shtick?</h3><div class="fb-comments" data-href="http://theredshtick.com/2017/02/07/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy/" data-numposts="8" data-width="530" data-colorscheme="light"></div>
<!-- NgfbSharing::get_buttons content filter skipped: post buttons are disabled -->
					
									</div><!-- .entry /-->


				<div class="share-post">
	<span class="share-text">Share</span>
	
		<ul class="flat-social">	
			<li><a href="http://www.facebook.com/sharer.php?u=http://wp.me/p2AWqC-aPL" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li>
		
			<li><a href="https://twitter.com/intent/tweet?text=GUEST+COLUMN%3A+%E2%80%9CBeing+a+U.S.+Senator+Completely+Fulfills+Me+in+Every+Way+Imaginable%E2%80%9D+%E2%80%94+John+Kennedy via %40redshtick&url=http://wp.me/p2AWqC-aPL" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li>
				<li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=http://wp.me/p2AWqC-aPL&amp;name=GUEST+COLUMN%3A+%E2%80%9CBeing+a+U.S.+Senator+Completely+Fulfills+Me+in+Every+Way+Imaginable%E2%80%9D+%E2%80%94+John+Kennedy" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li>
				<li><a href="http://www.stumbleupon.com/submit?url=http://wp.me/p2AWqC-aPL&title=GUEST+COLUMN%3A+%E2%80%9CBeing+a+U.S.+Senator+Completely+Fulfills+Me+in+Every+Way+Imaginable%E2%80%9D+%E2%80%94+John+Kennedy" class="social-stumble" rel="external" target="_blank"><i class="fa fa-stumbleupon"></i> <span>Stumbleupon</span></a></li>
					<li><a href="http://pinterest.com/pin/create/button/?url=http://wp.me/p2AWqC-aPL&amp;description=GUEST+COLUMN%3A+%E2%80%9CBeing+a+U.S.+Senator+Completely+Fulfills+Me+in+Every+Way+Imaginable%E2%80%9D+%E2%80%94+John+Kennedy&amp;media=http://theredshtick.com/wp-content/uploads/2017/02/Louisiana-Senator-John-Kennedy-heartfelt-660x330.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li>
		</ul>
		<div class="clear"></div>
</div> <!-- .share-post -->				<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2017-02-07T10:15:16+00:00","datePublished":"2017-02-07T10:15:16+00:00","dateModified":"2017-02-07T09:20:49+00:00","headline":"GUEST COLUMN: &#8220;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&#8221; \u2014 John Kennedy","name":"GUEST COLUMN: &#8220;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&#8221; \u2014 John Kennedy","keywords":"Current Events,Movies &amp; TV,Opinion,Politics,Religion","url":"http:\/\/theredshtick.com\/2017\/02\/07\/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy\/","description":"It took two party affiliations and three campaigns against three different opponents, but I finally made it. I am, at long last, a United States senator, and boy, does it feel dreamy. I'll be honest:","copyrightYear":"2017","publisher":{"@id":"#Publisher","@type":"Organization","name":"The Red Shtick","logo":{"@type":"ImageObject","url":"http:\/\/theredshtick.com\/wp-content\/uploads\/2016\/04\/TRS-logo_380x120.png"},"sameAs":["https:\/\/www.facebook.com\/TheRedShtick\/","https:\/\/twitter.com\/RedShtick","https:\/\/plus.google.com\/102895309969016331035"," ","https:\/\/www.youtube.com\/channel\/UCxf0phSz48-LYSyKAUU9tNQ","https:\/\/itunes.apple.com\/us\/podcast\/the-red-shtick\/id561142785?mt=2&amp;ls=1","https:\/\/goo.gl\/app\/playmusic?ibi=com.google.PlayMusic&amp;isi=691797987&amp;ius=googleplaymusic&amp;link=https:\/\/play.google.com\/music\/m\/Iav2kiscdtsrtrcfeyveu3dzy5y?t%3DThe_Red_Shtick_Podcast","https:\/\/www.instagram.com\/redshtick\/"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/theredshtick.com\/2017\/02\/07\/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy\/"},"author":{"@type":"Person","name":"Off the Wire Guest Columnist","url":"http:\/\/theredshtick.com\/author\/guest-columnist\/"},"articleSection":"Off the Wire","articleBody":"It took two party affiliations and three campaigns against three different opponents, but I finally made it. I am, at long last, a United States senator, and boy, does it feel dreamy.\n\nI'll be honest: I was worried it might not be all what it's cracked up to be. I was like, \"What if it's a let-down after working so hard to get there?\"&nbsp;\n\nWell, let me tell you: Being a U.S. senator completely fulfills me in every way imaginable. Physically. Emotionally. Spiritually. You name it.\n\nNow, I know some folks will say, \"But what about your family? What about your faith? Being senator couldn't be more fulfilling than having a loving, supportive family and serving a powerful, forgiving God. Right?\"\n\nWrong! Have you ever been a U.S. senator? If not, you have no idea what it's like!\n\nDo you have any idea what it\u2019s like to be able to look lovingly at Jeff Sessions and bat my brown, puppy dog eyes at him in admiration while telling him how awesome he is?\n\nSeriously, it's hard to describe how incredibly euphoric it is being a part of the upper house of the legislative branch of the federal government of the most powerful country on Earth. I've heard people talk about how they feel when the Holy Spirit takes over their bodies when they speak in tongues, or how people who go to Burning Man feel like they are one with the entire universe. It's like that all the time for me now that I'm a U.S. senator.\n\nRemember that movie Star Trek: Generations, the one with Captains Picard and Kirk? They had the Nexus, an extra-dimensional realm where everything was so perfect and fulfilling that you never wanted to leave. Remember? Whoopi Goldberg's character Guinan described it like this: \"It was like being inside joy. As if joy were something tangible, and you could wrap yourself up in it like a blanket.\"\n\nThat! That right there! That is exactly how being in the U.S. Senate is!\n\nNo wonder no one ever wants to leave this place! It's like being in the Nexus, except you don't have to blow up a sun to get in! But even if you did need to destroy an entire solar system to be elected, it would absolutely be worth the effort and sacrifice.\n\nTo be afforded the opportunity to sit in on the committee confirmation hearings for our next attorney general is the kind of stuff I had wet dreams about when I was just a boy growing up in Zachary.&nbsp;Do you have any idea what it's like to be able to look lovingly at Jeff Sessions and bat my brown, puppy dog eyes at him in admiration while telling him how awesome he is? And then to have him smile and nod back at me? My God, it's like I've died and gone to heaven.\n\nTo quote Josh Groban, \"I am filled with wonder. Sometimes, I think I glimpse eternity.\"\n\n&nbsp;","image":{"@type":"ImageObject","url":"http:\/\/theredshtick.com\/wp-content\/uploads\/2017\/02\/Louisiana-Senator-John-Kennedy-heartfelt.jpg","width":876,"height":493}}</script>
		</article><!-- .post-listing -->
		<p class="post-tag">Tags <a href="http://theredshtick.com/tag/current-events/" rel="tag">Current Events</a> <a href="http://theredshtick.com/tag/movies-tv/" rel="tag">Movies &amp; TV</a> <a href="http://theredshtick.com/tag/opinion/" rel="tag">Opinion</a> <a href="http://theredshtick.com/tag/politics/" rel="tag">Politics</a> <a href="http://theredshtick.com/tag/religion/" rel="tag">Religion</a></p>

		
				<section id="author-box">
			<div class="block-head">
				<h3>About Off the Wire Guest Columnist </h3><div class="stripe-line"></div>
			</div>
			<div class="post-listing">
				<div class="author-bio">
	<div class="author-avatar">
		<img src="http://2.gravatar.com/avatar/59b6ab5daa928a5e5f0d7b091ef934c4?s=90&#038;d=mm&#038;r=r" width="90" height="90" alt="" class="avatar avatar-90 wp-user-avatar wp-user-avatar-90 photo avatar-default" />	</div><!-- #author-avatar -->
			<div class="author-description">
								</div><!-- #author-description -->
			<div class="author-social flat-social">
									<a class="social-facebook" target="_blank" href="https://www.facebook.com/TheRedShtick"><i class="fa fa-facebook"></i></a>
									<a class="social-twitter" target="_blank" href="http://twitter.com/redshtick"><i class="fa fa-twitter"></i><span> @redshtick</span></a>
									<a class="social-google-plus" target="_blank" href="https://plus.google.com/102895309969016331035"><i class="fa fa-google-plus"></i></a>
															<a class="social-youtube" target="_blank" href="http://youtube.com/channel/UCxf0phSz48-LYSyKAUU9tNQ"><i class="fa fa-youtube"></i></a>
														</div>
		<div class="clear"></div>
</div>
				</div>
		</section><!-- #author-box -->
		

		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="http://theredshtick.com/2017/02/06/islamic-state-reaffirms-desire-to-kill-all-humanity-not-just-americans-despite-trumps-provocations/">
						<img width="293" height="165" src="http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" srcset="http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump.jpg 690w, http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump-250x141.jpg 250w, http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump-640x360.jpg 640w, http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump-300x169.jpg 300w" sizes="(max-width: 293px) 100vw, 293px" data-wp-pid="36966" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="http://theredshtick.com/2017/02/06/islamic-state-reaffirms-desire-to-kill-all-humanity-not-just-americans-despite-trumps-provocations/" rel="bookmark">Islamic State Reaffirms Desire to Kill All Humanity, Not Just Americans, Despite Trump&#8217;s Provocations</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>1 day ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="http://theredshtick.com/2017/02/03/kellyanne-conway-the-press-refuses-to-cover-that-thing-i-just-made-up/">
						<img width="310" height="165" src="http://theredshtick.com/wp-content/uploads/2017/02/Kellyanne-Conway-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" data-wp-pid="41646" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="http://theredshtick.com/2017/02/03/kellyanne-conway-the-press-refuses-to-cover-that-thing-i-just-made-up/" rel="bookmark">Kellyanne Conway: &#8220;The Press Refuses to Cover That Thing I Just Made Up&#8221;</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>4 days ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="http://theredshtick.com/2017/02/02/lsu-gordon-mckernan-agree-to-double-font-size-of-g-in-tigers/">
						<img width="310" height="165" src="http://theredshtick.com/wp-content/uploads/2017/01/LSU_Tiger_Stadium-Double-sized-G-310x165.png" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" data-wp-pid="41613" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="http://theredshtick.com/2017/02/02/lsu-gordon-mckernan-agree-to-double-font-size-of-g-in-tigers/" rel="bookmark">LSU, Gordon McKernan Agree to Double Font Size of ‘G’ in Tigers</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>5 days ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
<div id="VF6b4t6j_gK6g36ysKadPEL0txOrC2YDiLno2Ekl"></div>

			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<div class="post-thumbnail">
				<a href="http://theredshtick.com/2017/02/01/young-mother-upset-facebook-feed-constantly-reminding-her-she-brought-child-into-burgeoning-dystopia/">
					<img width="310" height="165" src="http://theredshtick.com/wp-content/uploads/2017/01/Young-Woman-Window-Serious-e1485967906567-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" data-wp-pid="41607" />					<span class="fa overlay-icon"></span>
				</a>
			</div><!-- post-thumbnail /-->
						
			<h2 class="post-title"><a href="http://theredshtick.com/2017/02/01/young-mother-upset-facebook-feed-constantly-reminding-her-she-brought-child-into-burgeoning-dystopia/" rel="bookmark">Young Mother Upset Facebook Feed Constantly Reminding Her She Brought Child Into Burgeoning Dystopia</a></h2>
			<p>A first-time mother would like her Facebook friends to stop filling her feed with posts indicating she chose to have a child on the eve of America unraveling into a dystopian nightmare.</p>
		</div>
			</section>
			
			
	
		
				
<div id="comments">


<div class="clear"></div>


</div><!-- #comments -->

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
		<div id="ads300_600-widget-3" class="e3lan-widget-content e3lan300-600">
								<div class="e3lan-cell">
				<div  class="paszone_container paszone-container-34630   " id="paszonecont_34630" style="overflow:hidden; max-width:300px;   " ><div class="pasinfotxt above"><small style="font-size:11px; color:#C0C0C0; text-decoration:none;"></small></div><div class="wppaszone proadszone-34630 " id="34630" style="overflow:hidden; width:300px; height:600px;  "><div class="wppasrotate   proadszoneholder-34630" style="" ><div class="pasli pasli-34631 "   duration="5000" bid="34631" aid="34630"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300 x 600 Large Skyscraper -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-6698439191164571"
     data-ad-slot="6188505938"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></div></div>
			</div>
				</div>
	<div id="categort-posts-widget-3" class="widget categort-posts"><div class="widget-top"><h4>RECENT SHTICK		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li >
							<div class="post-thumbnail">
					<a href="http://theredshtick.com/2017/02/07/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy/" rel="bookmark"><img width="110" height="75" src="http://theredshtick.com/wp-content/uploads/2017/02/Louisiana-Senator-John-Kennedy-heartfelt-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" data-wp-pid="41650" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://theredshtick.com/2017/02/07/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy/">GUEST COLUMN: &#8220;Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable&#8221; — John Kennedy</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>6 hours ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="http://theredshtick.com/2017/02/06/islamic-state-reaffirms-desire-to-kill-all-humanity-not-just-americans-despite-trumps-provocations/" rel="bookmark"><img width="110" height="62" src="http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" srcset="http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump.jpg 690w, http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump-250x141.jpg 250w, http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump-640x360.jpg 640w, http://theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump-300x169.jpg 300w" sizes="(max-width: 110px) 100vw, 110px" data-wp-pid="36966" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://theredshtick.com/2017/02/06/islamic-state-reaffirms-desire-to-kill-all-humanity-not-just-americans-despite-trumps-provocations/">Islamic State Reaffirms Desire to Kill All Humanity, Not Just Americans, Despite Trump&#8217;s Provocations</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>1 day ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="http://theredshtick.com/2017/02/03/kellyanne-conway-the-press-refuses-to-cover-that-thing-i-just-made-up/" rel="bookmark"><img width="110" height="75" src="http://theredshtick.com/wp-content/uploads/2017/02/Kellyanne-Conway-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" data-wp-pid="41646" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://theredshtick.com/2017/02/03/kellyanne-conway-the-press-refuses-to-cover-that-thing-i-just-made-up/">Kellyanne Conway: &#8220;The Press Refuses to Cover That Thing I Just Made Up&#8221;</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>4 days ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="http://theredshtick.com/2017/02/02/lsu-gordon-mckernan-agree-to-double-font-size-of-g-in-tigers/" rel="bookmark"><img width="110" height="75" src="http://theredshtick.com/wp-content/uploads/2017/01/LSU_Tiger_Stadium-Double-sized-G-110x75.png" class="attachment-tie-small size-tie-small wp-post-image" alt="" data-wp-pid="41613" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://theredshtick.com/2017/02/02/lsu-gordon-mckernan-agree-to-double-font-size-of-g-in-tigers/">LSU, Gordon McKernan Agree to Double Font Size of ‘G’ in Tigers</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>5 days ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="http://theredshtick.com/2017/02/01/young-mother-upset-facebook-feed-constantly-reminding-her-she-brought-child-into-burgeoning-dystopia/" rel="bookmark"><img width="110" height="75" src="http://theredshtick.com/wp-content/uploads/2017/01/Young-Woman-Window-Serious-e1485967906567-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" data-wp-pid="41607" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="http://theredshtick.com/2017/02/01/young-mother-upset-facebook-feed-constantly-reminding-her-she-brought-child-into-burgeoning-dystopia/">Young Mother Upset Facebook Feed Constantly Reminding Her She Brought Child Into Burgeoning Dystopia</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>6 days ago</span>		</li>
						</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /-->	<div class="flexslider" id="tie-slider-widget-3">
		<ul class="slides">
					<li>
							<a href="http://theredshtick.com/2017/02/03/there-can-be-only-one-the-podcast-43-standoff/">
				<img width="310" height="205" src="http://theredshtick.com/wp-content/uploads/2017/02/standOffPoster-310x205.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="" data-wp-pid="41621" />				</a>
							<div class="slider-caption">
					<h2><a href="http://theredshtick.com/2017/02/03/there-can-be-only-one-the-podcast-43-standoff/">There Can Be Only One – The Podcast 43: &#8220;Standoff&#8221;</a></h2>
				</div>
			</li>
					<li>
							<a href="http://theredshtick.com/2017/02/02/the-red-shtick-podcast-episode-215-pedophiles-can-own-dogs-too/">
				<img width="310" height="205" src="http://theredshtick.com/wp-content/uploads/2017/02/Ascension-Parish_missing-dog-310x205.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="" data-wp-pid="41633" />				</a>
							<div class="slider-caption">
					<h2><a href="http://theredshtick.com/2017/02/02/the-red-shtick-podcast-episode-215-pedophiles-can-own-dogs-too/">The Red Shtick Podcast, Episode 215: &#8220;Pedophiles Can Own Dogs, Too&#8221;</a></h2>
				</div>
			</li>
					<li>
							<a href="http://theredshtick.com/2017/02/01/dorque-episode-139-thats-news-to-me/">
				<img width="205" height="205" src="http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400.png" class="attachment-tie-large size-tie-large wp-post-image" alt="" srcset="http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400.png 1400w, http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400-150x150.png 150w, http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400-250x250.png 250w, http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400-800x800.png 800w, http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400-200x200.png 200w, http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400-300x300.png 300w" sizes="(max-width: 205px) 100vw, 205px" data-wp-pid="32089" />				</a>
							<div class="slider-caption">
					<h2><a href="http://theredshtick.com/2017/02/01/dorque-episode-139-thats-news-to-me/">Dorque, Episode 139: That&#8217;s News to Me</a></h2>
				</div>
			</li>
					<li>
							<a href="http://theredshtick.com/2017/01/27/there-can-be-only-one-the-podcast-42-split/">
				<img width="310" height="205" src="http://theredshtick.com/wp-content/uploads/2017/01/splitPoster-310x205.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="" data-wp-pid="41487" />				</a>
							<div class="slider-caption">
					<h2><a href="http://theredshtick.com/2017/01/27/there-can-be-only-one-the-podcast-42-split/">There Can Be Only One – The Podcast 42: &#8220;Split&#8221;</a></h2>
				</div>
			</li>
					<li>
							<a href="http://theredshtick.com/2017/01/26/the-red-shtick-podcast-episode-214-cash-me-at-rub-n-tug-how-bow-dah/">
				<img width="310" height="205" src="http://theredshtick.com/wp-content/uploads/2017/01/Massage-Parlor-Prostitution-arrest-Baton-Rouge-310x205.jpg" class="attachment-tie-large size-tie-large wp-post-image" alt="" data-wp-pid="41499" />				</a>
							<div class="slider-caption">
					<h2><a href="http://theredshtick.com/2017/01/26/the-red-shtick-podcast-episode-214-cash-me-at-rub-n-tug-how-bow-dah/">The Red Shtick Podcast, Episode 214: &#8220;Cash Me at Rub-N-Tug. How Bow Dah?&#8221;</a></h2>
				</div>
			</li>
					<li>
							<a href="http://theredshtick.com/2017/01/25/dorque-episode-138-han-job-prease/">
				<img width="205" height="205" src="http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400.png" class="attachment-tie-large size-tie-large wp-post-image" alt="" srcset="http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400.png 1400w, http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400-150x150.png 150w, http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400-250x250.png 250w, http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400-800x800.png 800w, http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400-200x200.png 200w, http://theredshtick.com/wp-content/uploads/2015/03/Dorque-Podcast-logo-1400-300x300.png 300w" sizes="(max-width: 205px) 100vw, 205px" data-wp-pid="32089" />				</a>
							<div class="slider-caption">
					<h2><a href="http://theredshtick.com/2017/01/25/dorque-episode-138-han-job-prease/">Dorque, Episode 138: Han Job Prease?</a></h2>
				</div>
			</li>
				</ul>
	</div>
			<script>
	jQuery(document).ready(function() {
	  jQuery('#tie-slider-widget-3').flexslider({
		animation: "fade",
		slideshowSpeed: 7000,
		animationSpeed: 600,
		randomize: false,
		pauseOnHover: true,
		prevText: "",
		nextText: "",
		controlNav: false
	  });
	});
	</script>
		<div class="arqam-lite-widget-counter gray">
		<ul>
				<li class="arq-lite-facebook">
				<a href="http://www.facebook.com/TheRedShtick" target="_blank" >
					<i class="fa fa-facebook"></i>
					<span>3,890</span>
					<small>Likes</small>
				</a>
			</li>
					<li class="arq-lite-twitter">
				<a href="http://twitter.com/redshtick" target="_blank" >
					<i class="fa fa-twitter"></i>
					<span>695</span>
					<small>Followers</small>
				</a>
			</li>
					<li class="arq-lite-instagram">
				<a href="http://instagram.com/redshtick" target="_blank" >
					<i class="fa fa-instagram"></i>
					<span>12</span>
					<small>Followers</small>
				</a>
			</li>
		
			</ul>
		</div>
		<!-- arqam_lite Social Counter Plugin : http://codecanyon.net/user/TieLabs/portfolio?ref=TieLabs -->
		<div id="ads300_250-widget-3" class="e3lan-widget-content e3lan300-250">
								<div class="e3lan-cell">
				<div  class="paszone_container paszone-container-34383   " id="paszonecont_34383" style="overflow:hidden; max-width:300px; margin: 0 auto; text-align:center;  " ><div class="pasinfotxt above"><small style="font-size:11px; color:#C0C0C0; text-decoration:none;"></small></div><div class="wppaszone proadszone-34383 " id="34383" style="overflow:hidden; max-width:300px; max-height:250px; margin: 0 auto; text-align:center; "><div class="wppasrotate rotating_paszone wppasrotate421462819 proadszoneholder-34383" style="" ><div class="pasli pasli-34394 "   duration="15000" bid="34394" aid="34383"><a class="wpproaddlink" href="http://theredshtick.com?pasID=MzQzOTQ=&amp;pasZONE=MzQzODM=" target="_blank" rel="nofollow"><img src="http://theredshtick.com/wp-content/uploads/2015/09/KateJeansonne-APR13-300x250-v2.png?pas=1178564011702072231" alt="Kate at Fabians 300&#215;250" border="0"  /></a></div><div class="pasli pasli-34386 "   duration="15000" bid="34386" aid="34383"><a class="wpproaddlink" href="http://theredshtick.com?pasID=MzQzODY=&amp;pasZONE=MzQzODM=" target="_blank" rel="nofollow"><img src="http://theredshtick.com/wp-content/uploads/2014/03/BrakesAndMore-APR13-300x250.png?pas=4600976801702072231" alt="Brakes And More – checklist ad" border="0"  /></a></div><div class="pasli pasli-34399 "   duration="15000" bid="34399" aid="34383"><a class="wpproaddlink" href="http://theredshtick.com?pasID=MzQzOTk=&amp;pasZONE=MzQzODM=" target="_blank" rel="nofollow"><img src="http://theredshtick.com/wp-content/uploads/2015/09/TRS-Lucianas-Nov12-ver2.png?pas=13854802191702072231" alt="Lucianas 300&#215;250 – Now offering yoga" border="0"  /></a></div><div class="pasli pasli-34391 "   duration="15000" bid="34391" aid="34383"><a class="wpproaddlink" href="http://theredshtick.com?pasID=MzQzOTE=&amp;pasZONE=MzQzODM=" target="_blank" rel="nofollow"><img src="http://theredshtick.com/wp-content/uploads/2015/09/Jay-Ducote-BBQ-Sauce-300x250.png?pas=14633351311702072231" alt="Jay Ducote: BBQ Sauce 300&#215;250" border="0"  /></a></div></div></div></div><script type="text/javascript">jQuery(window).load(function(){jQuery(function($){var slider_wppasrotate421462819 = $(".wppasrotate421462819").bxSlider({ mode: "fade",slideMargin: 5,autoHover: true,adaptiveHeight: true,pager: false,controls: false,auto: true,pause: $(".wppasrotate421462819").find(".pasli").first().attr("duration"),preloadImages: "all",onSliderLoad: function(currentIndex){ $(".wppasrotate421462819").find(".pasli").css("visibility", "visible");},onSlideAfter: function( $slideElement, oldIndex, newIndex ){ slider_wppasrotate421462819.setPause($($slideElement).attr("duration"));},});});});</script>
			</div>
				</div>
	<div id="top-posts-12" class="widget widget_top-posts"><div class="widget-top"><h4>RED HOT SHTICK</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><ul class='widgets-list-layout no-grav'>
					<li>
												<a href="http://theredshtick.com/2017/02/06/islamic-state-reaffirms-desire-to-kill-all-humanity-not-just-americans-despite-trumps-provocations/" title="Islamic State Reaffirms Desire to Kill All Humanity, Not Just Americans, Despite Trump&#039;s Provocations" class="bump-view" data-bump-view="tp">
														<img width="0" height="0" src="https://i0.wp.com/theredshtick.com/wp-content/uploads/2016/03/ISIS-Donald-Trump.jpg?resize=0%2C0" class='widgets-list-layout-blavatar' alt="Islamic State Reaffirms Desire to Kill All Humanity, Not Just Americans, Despite Trump&#039;s Provocations" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://theredshtick.com/2017/02/06/islamic-state-reaffirms-desire-to-kill-all-humanity-not-just-americans-despite-trumps-provocations/" class="bump-view" data-bump-view="tp">
								Islamic State Reaffirms Desire to Kill All Humanity, Not Just Americans, Despite Trump&#039;s Provocations							</a>
						</div>
											</li>
									<li>
												<a href="http://theredshtick.com/2016/04/05/quiz-melania-or-madison/" title="QUIZ: Melania or Madison?" class="bump-view" data-bump-view="tp">
														<img width="0" height="0" src="https://i1.wp.com/theredshtick.com/wp-content/uploads/2016/04/Melania-Trump-Madison-Ivy.jpg?resize=0%2C0" class='widgets-list-layout-blavatar' alt="QUIZ: Melania or Madison?" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://theredshtick.com/2016/04/05/quiz-melania-or-madison/" class="bump-view" data-bump-view="tp">
								QUIZ: Melania or Madison?							</a>
						</div>
											</li>
									<li>
												<a href="http://theredshtick.com/2017/02/02/lsu-gordon-mckernan-agree-to-double-font-size-of-g-in-tigers/" title="LSU, Gordon McKernan Agree to Double Font Size of ‘G’ in Tigers" class="bump-view" data-bump-view="tp">
														<img width="0" height="0" src="https://i0.wp.com/theredshtick.com/wp-content/uploads/2017/01/LSU_Tiger_Stadium-Double-sized-G.png?resize=0%2C0" class='widgets-list-layout-blavatar' alt="LSU, Gordon McKernan Agree to Double Font Size of ‘G’ in Tigers" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://theredshtick.com/2017/02/02/lsu-gordon-mckernan-agree-to-double-font-size-of-g-in-tigers/" class="bump-view" data-bump-view="tp">
								LSU, Gordon McKernan Agree to Double Font Size of ‘G’ in Tigers							</a>
						</div>
											</li>
									<li>
												<a href="http://theredshtick.com/2017/01/27/trump-strategist-steve-bannon-the-press-needs-to-shut-up-blow-me-and-make-me-a-sandwich/" title="Trump Strategist Steve Bannon: &quot;The Press Needs to Shut Up, Blow Me, and Make Me a Sandwich&quot;" class="bump-view" data-bump-view="tp">
														<img width="0" height="0" src="https://i2.wp.com/theredshtick.com/wp-content/uploads/2017/01/Steve-Bannon-headset.jpg?resize=0%2C0" class='widgets-list-layout-blavatar' alt="Trump Strategist Steve Bannon: &quot;The Press Needs to Shut Up, Blow Me, and Make Me a Sandwich&quot;" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://theredshtick.com/2017/01/27/trump-strategist-steve-bannon-the-press-needs-to-shut-up-blow-me-and-make-me-a-sandwich/" class="bump-view" data-bump-view="tp">
								Trump Strategist Steve Bannon: &quot;The Press Needs to Shut Up, Blow Me, and Make Me a Sandwich&quot;							</a>
						</div>
											</li>
									<li>
												<a href="http://theredshtick.com/2017/01/18/quiz-never-forget-or-get-over-it-how-real-an-american-are-you/" title="QUIZ: &quot;Never Forget&quot; or &quot;Get Over It&quot;? How Real an American Are You?" class="bump-view" data-bump-view="tp">
														<img width="0" height="0" src="https://i1.wp.com/theredshtick.com/wp-content/uploads/2017/01/Slave-back-scars.jpg?resize=0%2C0" class='widgets-list-layout-blavatar' alt="QUIZ: &quot;Never Forget&quot; or &quot;Get Over It&quot;? How Real an American Are You?" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://theredshtick.com/2017/01/18/quiz-never-forget-or-get-over-it-how-real-an-american-are-you/" class="bump-view" data-bump-view="tp">
								QUIZ: &quot;Never Forget&quot; or &quot;Get Over It&quot;? How Real an American Are You?							</a>
						</div>
											</li>
									<li>
												<a href="http://theredshtick.com/2017/01/25/chick-fil-a-now-offering-sunday-service-to-customers-going-to-hell/" title="Chick-fil-A Now Opening on Sundays for Customers Going to Hell" class="bump-view" data-bump-view="tp">
														<img width="0" height="0" src="https://i2.wp.com/theredshtick.com/wp-content/uploads/2017/01/Chick-fil-a-e1485273034358.jpg?resize=0%2C0" class='widgets-list-layout-blavatar' alt="Chick-fil-A Now Opening on Sundays for Customers Going to Hell" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="http://theredshtick.com/2017/01/25/chick-fil-a-now-offering-sunday-service-to-customers-going-to-hell/" class="bump-view" data-bump-view="tp">
								Chick-fil-A Now Opening on Sundays for Customers Going to Hell							</a>
						</div>
											</li>
				</ul>
</div></div><!-- .widget /--><div id="mc4wp_form_widget-9" class="widget widget_mc4wp_form_widget"><div class="widget-top"><h4>Shtick in the Box (Weekly Newsletter)</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- MailChimp for WordPress v4.0 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-35634 mc4wp-form-basic" method="post" data-id="35634" data-name="Default sign-up form" ><div class="mc4wp-form-fields"><p>
	<label for="mc4wp_email">Where shall we Sht!ck it to you? </label>
	<input type="email" id="mc4wp_email" name="EMAIL" required placeholder="Your email address" />
</p>

<p>
	<input type="submit" value="Sign up" />
</p><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></div><input type="hidden" name="_mc4wp_timestamp" value="1486506713" /><input type="hidden" name="_mc4wp_form_id" value="35634" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /></div><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin --></div></div><!-- .widget /-->		<div id="ads300_100-widget-2" class="e3lan-widget-content e3lan300-100">
								<div class="e3lan-cell">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Link ad - responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6698439191164571"
     data-ad-slot="5769294335"
     data-ad-format="link"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
			</div>
													</div>
			<div id="ads300_250-widget-4" class="e3lan-widget-content e3lan300-250">
								<div class="e3lan-cell">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-6698439191164571"
     data-ad-slot="1339094730"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
			</div>
				</div>
		</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-3c">

			<div id="footer-first" class="footer-widgets-box">
			<div id="latest_tweets_widget-2" class="footer-widget twitter-widget"><div class="footer-widget-top"><h4>			<a href="http://twitter.com/@redshtick">Latest Tweets</a>
		</h4></div>
						<div class="footer-widget-container">
<div class="twitter-widget-content" >
<ul class="twitter_update_list">
<li class="twitter-item">
	<i class="fa fa-twitter"></i>"Not All Trump Supporters Are Bigots" Claims Woman Who Says All Muslims Are Terrorists <a href="https://t.co/kC7gyhqTkB" class="twitter-link">https://t.co/kC7gyhqTkB</a> <a href="https://t.co/N6CNYzidU2" class="twitter-link">https://t.co/N6CNYzidU2</a><small class="twitter-timestamp"><abbr title="2017/02/07 22:05:03">27 mins ago</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>When's the last time you got a Sht!ck in your box? Sign up for our newsletter &amp; we'll Sht!ck it you good every week.
<a href="https://t.co/sIndtxbOv0" class="twitter-link">https://t.co/sIndtxbOv0</a><small class="twitter-timestamp"><abbr title="2017/02/07 19:00:12">4 hours ago</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>"Get Over It! Trump's Our President," Insists Founder of "Impeach the Kenyan Muslim Nazi" Website… <a href="https://t.co/Q4RuyETKsA" class="twitter-link">https://t.co/Q4RuyETKsA</a><small class="twitter-timestamp"><abbr title="2017/02/07 18:00:21">5 hours ago</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>GUEST COLUMN: "Being a U.S. Senator Completely Fulfills Me in Every Way Imaginable" — John Kennedy… <a href="https://t.co/oDEV0voPnx" class="twitter-link">https://t.co/oDEV0voPnx</a><small class="twitter-timestamp"><abbr title="2017/02/07 16:15:26">6 hours ago</abbr></small></li>
</ul> </div>
		</div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
			<div id="podpressaddons-widget-9" class="footer-widget podPressADDONS_Widget_Class"><div class="footer-widget-top"><h4>latest podcasts (pop-out player)</h4></div>
						<div class="footer-widget-container"><ul style="margin: 0;">
<li class="powerPressADDONS-Link"><a href="#powerPressPlayer" class="powerpress_playinpopup_audio/mpeg" onclick="window.open('?powerpress_pinw=41620-podcast', 'podcast-41620', 'width=360,height=24,toolbar=0'); return false;">There Can Be Only One – The Podcast 43: &#8220;Standoff&#8221;</a></li>
<li class="powerPressADDONS-Link"><a href="#powerPressPlayer" class="powerpress_playinpopup_audio/mpeg" onclick="window.open('?powerpress_pinw=41622-podcast', 'podcast-41622', 'width=360,height=24,toolbar=0'); return false;">The Red Shtick Podcast, Episode 215: &#8220;Pedophiles Can Own Dogs, Too&#8221;</a></li>
<li class="powerPressADDONS-Link"><a href="#powerPressPlayer" class="powerpress_playinpopup_audio/mpeg" onclick="window.open('?powerpress_pinw=41574-podcast', 'podcast-41574', 'width=360,height=24,toolbar=0'); return false;">Dorque, Episode 139: That&#8217;s News to Me</a></li>
<li class="powerPressADDONS-Link"><a href="#powerPressPlayer" class="powerpress_playinpopup_audio/mpeg" onclick="window.open('?powerpress_pinw=41486-podcast', 'podcast-41486', 'width=360,height=24,toolbar=0'); return false;">There Can Be Only One – The Podcast 42: &#8220;Split&#8221;</a></li>
<li class="powerPressADDONS-Link"><a href="#powerPressPlayer" class="powerpress_playinpopup_audio/mpeg" onclick="window.open('?powerpress_pinw=41498-podcast', 'podcast-41498', 'width=360,height=24,toolbar=0'); return false;">The Red Shtick Podcast, Episode 214: &#8220;Cash Me at Rub-N-Tug. How Bow Dah?&#8221;</a></li>
<li class="powerPressADDONS-Link"><a href="#powerPressPlayer" class="powerpress_playinpopup_audio/mpeg" onclick="window.open('?powerpress_pinw=41462-podcast', 'podcast-41462', 'width=360,height=24,toolbar=0'); return false;">Dorque, Episode 138: Han Job Prease?</a></li>
<li class="powerPressADDONS-Link"><a href="#powerPressPlayer" class="powerpress_playinpopup_audio/mpeg" onclick="window.open('?powerpress_pinw=41336-podcast', 'podcast-41336', 'width=360,height=24,toolbar=0'); return false;">There Can Be Only One – The Podcast 41: &#8220;Fortress&#8221;</a></li>
<li class="powerPressADDONS-Link"><a href="#powerPressPlayer" class="powerpress_playinpopup_audio/mpeg" onclick="window.open('?powerpress_pinw=41339-podcast', 'podcast-41339', 'width=360,height=24,toolbar=0'); return false;">The Red Shtick Podcast, Episode 213: &#8220;Heebies From the GBs&#8221;</a></li>
</ul>
</div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

			<div id="footer-third" class="footer-widgets-box">
			<div id="mc4wp_form_widget-7" class="footer-widget widget_mc4wp_form_widget"><div class="footer-widget-top"><h4>Get a Sht!ck in the box (weekly update)</h4></div>
						<div class="footer-widget-container"><!-- MailChimp for WordPress v4.0 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-35634 mc4wp-form-basic" method="post" data-id="35634" data-name="Default sign-up form" ><div class="mc4wp-form-fields"><p>
	<label for="mc4wp_email">Where shall we Sht!ck it to you? </label>
	<input type="email" id="mc4wp_email" name="EMAIL" required placeholder="Your email address" />
</p>

<p>
	<input type="submit" value="Sign up" />
</p><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></div><input type="hidden" name="_mc4wp_timestamp" value="1486506713" /><input type="hidden" name="_mc4wp_form_id" value="35634" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2" /></div><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin --></div></div><!-- .widget /--><div id="login-widget-2" class="footer-widget login-widget"><div class="footer-widget-top"><h4>Login</h4></div>
						<div class="footer-widget-container">		<div id="login-form">
			<form name="loginform" id="loginform" action="http://theredshtick.com/wp-login.php" method="post">
				<p id="log-username"><input type="text" name="log" id="log" title="Username" value="Username" onfocus="if (this.value == 'Username') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Username';}"  size="33" /></p>
				<p id="log-pass"><input type="password" name="pwd" id="pwd" title="Password" value="Password" onfocus="if (this.value == 'Password') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Password';}" size="33" /></p>
				<input type="submit" name="submit" value="Log in" class="login-button" />
				<label for="rememberme"><input name="rememberme" id="rememberme" type="checkbox" checked="checked" value="forever" /> Remember Me</label>
				<input type="hidden" name="redirect_to" value="/2017/02/07/guest-column-being-a-u-s-senator-completely-fulfills-me-in-every-way-imaginable-john-kennedy/"/>
			</form>
			<ul class="login-links">
								<li><a href="http://theredshtick.com/wp-login.php?action=lostpassword&redirect_to=http://theredshtick.com">Lost your password?</a></li>
			</ul>
		</div>
	</div></div><!-- .widget /-->		</div><!-- #third .widget-area -->
	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			Powered by <a href="http://wordpress.org">WordPress</a> | Designed by <a href="http://tielabs.com/">TieLabs</a>		</div>
				<div class="social-icons">
		<a class="ttip-none" title="Rss" href="http://theredshtick.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Google+" href="https://plus.google.com/102895309969016331035" target="_blank"><i class="fa fa-google-plus"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/TheRedShtick/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/RedShtick" target="_blank"><i class="fa fa-twitter"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/channel/UCxf0phSz48-LYSyKAUU9tNQ" target="_blank"><i class="fa fa-youtube"></i></a><a class="ttip-none" title="Apple" href="https://itunes.apple.com/us/podcast/the-red-shtick/id561142785?mt=2&#038;ls=1" target="_blank"><i class="fa fa-apple"></i></a><a class="ttip-none" title="instagram" href="https://www.instagram.com/redshtick/" target="_blank"><i class="fa fa-instagram"></i></a><a class="ttip-none" title="Google Play" href="https://goo.gl/app/playmusic?ibi=com.google.PlayMusic&#038;isi=691797987&#038;ius=googleplaymusic&#038;link=https://play.google.com/music/m/Iav2kiscdtsrtrcfeyveu3dzy5y?t%3DThe_Red_Shtick_Podcast" target="_blank"><i class="fa fa-play"></i></a>
			</div>

		
		<div class="alignleft">
			© Copyright 2017 The Red Shtick, All Rights Reserved		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-includes/js/jquery/ui/effect.min.js'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-includes/js/jquery/ui/effect-shake.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"mac","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","SmothScroll":"true","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theredshtick.com/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-content/themes/sahifa/js/search.js'></script>
<script type='text/javascript' src='//api.content-ad.net/Scripts/widget2.aspx?id=a3ee73d2-383a-49f7-b219-b6354882604d&#038;d=dGhlcmVkc2h0aWNrLmNvbQ%3D%3D&#038;wid=36433&#038;cb=1.48650671308E+12'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wppas_ajax_script = {"ajaxurl":"http:\/\/theredshtick.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theredshtick.com/wp-content/plugins/wp_pro_ad_system/templates/js/wppas.min.js'></script>
<script type='text/javascript' src='//api.content-ad.net/Scripts/widget2.aspx?id=c9531aa2-f402-4353-b1ca-e243436c0f08&#038;d=dGhlcmVkc2h0aWNrLmNvbQ%3D%3D&#038;wid=310958&#038;cb=1.4865067131E+12'></script>
<script type='text/javascript' src='http://theredshtick.com/wp-content/plugins/wp_pro_ad_system/templates/js/jquery.bxslider.min.pas.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='http://theredshtick.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='http://theredshtick.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js'></script>
<![endif]-->
<script>jQuery(document).ready(function () {clammrPlugin.MediaPlayer.init('.clammr-player audio');});</script>	<div style="display:none">
	<div class="grofile-hash-map-59b6ab5daa928a5e5f0d7b091ef934c4">
	</div>
	</div>
<script src="https://s.newsmaxfeednetwork.com/static/js/connectV5.js">
</script>

  <script type="text/javascript">
  NM.init({
         widgetId: "VF6b4t6j_gK6g36ysKadPEL0txOrC2YDiLno2Ekl",
         template: "NM01"
   });
   </script> <script type="text/javascript">(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=425616237478481&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<!-- ngfb footer: post buttons are disabled -->
<script type='text/javascript' src='http://stats.wp.com/e-201706.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.5',blog:'38357082',post:'41649',tz:'-6',srv:'theredshtick.com'} ]);
	_stq.push([ 'clickTrackerInit', '38357082', '41649' ]);
</script>
</body>
</html>